• Samba user shares readonly


    I set up samba according to the excellent wiki article, but now when I create a user share from gnome it gets created as read only. it used to work fine, I could create a user share and mount it without issue, not sure what changed. I’ve not changed anything. Help getting this sorted out would be much appreciated.

  • @galvez_65 said in Samba user shares readonly:

    I set up samba according to the excellent wiki article, but now when I create a user share from gnome it gets created as read only. it used to work fine, I could create a user share and mount it without issue, not sure what changed. I’ve not changed anything. Help getting this sorted out would be much appreciated.

    First I am assuming the Server computer is Linux based.

    I would start by checking the /etc/samba/smb.conf file on the computer acting as the Samba server. Somewhere in this file should be a section that sets up the samba share. It should look something like this.

     [MyShare] 
     comment = Samba Share 
     path = /server 
     valid users = jack sally 
     public = no 
     writeable = yes 
     printable = no 
     create mask =0765  
    

    [MyShare] (name of samba share, it is case sensitive when addressing it)
    comment = Samba Share (shows up in client computer)
    path = /server (path to the Server directory to be shared)
    valid users = jack sally (Client Users allowed to share)
    public = no (Allows share to appear in Windows shared directories??)
    writeable = yes (allows client to write files, May also see readonly= yes)
    printable = no (self explanatory)
    create mask =0765

    Create mask is like the permissions in linux such as
    rwxrw-r–
    rwx read, write, execute = 7
    rw- read, write NO execute = 6
    r-- read only

    In the create mask show above we have
    owner = 7 (read, Wright, execute)
    Group = 6 (Read, Wright no execute)
    others = 5 (Read, no wright, execute)

    So, the two lines to check are
    readonly= yes OR writeable=yes
    and
    create mask

    HTH

  • @pudge
    correct the server is linux. I don’t have any predefined shares set up in my smb.conf file, but rather have usershares turned with this code in the smb.conf

    [global]
    	bind interfaces only = Yes
    	dns proxy = No
    	interfaces = lo enp3s0
    	log file = /var/log/samba/log.%m
    	max log size = 50
    	server role = standalone server
    	server string = Puker Server
    	usershare allow guests = Yes
    	usershare max shares = 100
    	usershare path = /var/lib/samba/usershare
    	idmap config * : backend = tdb
    
    

    I’ve checked all the folder permissions and they all seem correct

  • As Samba is one of those necessary evils, I tend to keep it as simple as possible and use the system-config-samba utility. Other than occasionally having to change the name resolve order on some Ubuntu systems, I haven’t touched a smb.conf file in years.

  • the issue is with nautilus not samba. If I right click on a folder and select share folder it does not add proper acl permissions to the share

  • The odd thing is it works on Ubuntu but not Antergos.

  • Setting the shares up with system-config-samba does set the permissions correctly. Running testparm after setting things up helps find problems ahead of time, too.

samba34 shares5 readonly1 Posts 7Views 184
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.