• Video Drivers Problem?


    Using antergos KDE for weeks and the main thing that annoys me is display. My system is Intel i5 8400, which has integrated GPU (UHD 630). During installation, I selected option to auto find and install free drivers. So far, I have these problems:

    1. Sometimes, display switches between different views several times a second, which means flickering. It’s difficult to explain, but I’ll try my best. For example, when I view text in Geany and scroll text down (up), “old” text (located at the top) should be hidden and “new” text (located at the bottom) should be displayed instead of “old” text. Unfortunately, it displays both old/new texts, switching between them several times a second. The only way to stop this flickering - scroll text again.
      Or another example - when I change column width in LibreCalc, it displays line of old column and also line of new (resized) column at the same time, switching between them several times a second. Once again, the only way to stop flickering - resize column again.

    2. Some apps display text and/or GUI elements (progress bars, etc.) incorrectly or don’t display them at all.
      For example, here’s how LibreOffice interface looks - https://s33.postimg.cc/n8dgwxui7/libre.png (as you see, checkboxes/radio boxes look awful)
      Deepin player - https://s33.postimg.cc/xv7a2kkpr/deepin.png (as you see, title bar is white and text is invisible, while it should be dark and text should be visible)
      The same goes for other apps too. For example, Sound Converter doesn’t display a progress bar when processing audio.

    It’s important to mention that problems listed above don’t happen all the time. Usually, they only occur 2 times out of 10, but still annoy me as hell. What should I start looking at?

  • In addition to this, I also experience scroll lag problem, which usually happens 99% of time. When I scroll text/page in any app, it takes some amount of time (maybe half a second or so) to update displayed content.

  • I am no expert but I’ll give it a try.
    for flickering issue only:
    cat /etc/mkinitcpio.conf
    do you have this: MODULES=(... i915 ...)
    if you have Nvidia, there should be nouveau

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Thanks for your reply. I only have this:

    MODULES=“ext4”

    I don’t think UHD630 is made by Nvidia? It’s a GPU integrated into Intel CPU itself…

  • You can check dmesg in terminal and see if there’s error messages there, usually hardware/driver related.

    journalctl prints a lot of stuff but is definitively worth a look as it shows errors from “everything”.

    I would also uninstall “xf86-video-intel” if you have that, and give it a shot without. It has been problematic on my mini-PC boxes (sky/kaby lake I think).

    I have KDE on 2 laptops and 3 desktops and it’s a long since I’ve had issues with it.

  • dmesg doesn’t show any serious errors. So far, only this error is displayed:

    [   15.312697] kvm: disabled by bios
    [   15.393805] iTCO_wdt iTCO_wdt: can't request region for resource [mem 0x00c5fffc-0x00c5ffff]
    

    xf86-video-intel is not installed on my system. I guess it would be installed by default if I selected to use proprietary video drivers during antergos installation?

  • @toxpal said in Video Drivers Problem?:

    xf86-video-intel

    is not needed by newer intel GPU’S and it is recommended to use modsetting driver.

    https://wiki.archlinux.org/index.php/Intel_graphics#Installation

    [updates once a week] = [90% less problems]
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    help development: donate antergos

  • Thanks guys, that’s a lot of information to read… Took me some time…

    @modisc said in Video Drivers Problem?:

    for flickering issue only:
    cat /etc/mkinitcpio.conf
    do you have this: MODULES=(… i915 …)

    While I don’t have this entry in specified file, instructions in other sources suggest that i915 is actually loaded on my system. For example - https://carlosbecker.com/posts/how-to-enable-kms-on-i915-graphiccard-archlinux/

    cat /sys/module/i915/parameters/modeset returns 1 for me, /etc/modprobe.d/i915.conf also has entry options i915 modeset=1 and so on. Do I still need to edit mkinitcpio.conf in this case?

  • @joekamprad said in Video Drivers Problem?:

    https://wiki.archlinux.org/index.php/Intel_graphics#Installation

    Yes, I always try to search all the sources before asking for assistance, and I think most of the steps are completed in my system, but the issue still remains. For example:

    Install the mesa package, which provides the DRI driver for 3D acceleration.

    mesa is installed.

    Make sure you do not have nomodeset or vga= as a kernel parameter, since Intel requires kernel mode-setting.
    Also, check that you have not disabled Intel by using any modprobe blacklisting within /etc/modprobe.d/ or /usr/lib/modprobe.d/.

    Check.

    Kernel mode setting (KMS) is supported by Intel chipsets that use the i915 DRM driver and is mandatory and enabled by default.

    If it’s enabled by default, I guess nothing else to do…

    It is necessary to add i915.enable_guc=3 to the kernel parameters to enable both GuG and HuC firmware loading.

    This one was not enabled on my system did it. Unfortunately, no effect.

    However, to take advantage of some driver options, you will need to create a Xorg configuration file

    Completed this one too.

    The SNA acceleration method causes tearing for some people. To fix this, enable the “TearFree” option

    Done.

    What else do I miss here?

  • @toxpal said in Video Drivers Problem?:

    cat /sys/module/i915/parameters/modeset returns 1 for me, /etc/modprobe.d/i915.conf also has entry options i915 modeset=1 and so on. Do I still need to edit mkinitcpio.conf in this case?

    Hi. No, I don’t believe so.
    If my knowledge base is correct on this, 1 suggests that it’s available on your system.
    However, like all things I may need to be corrected if I’m wrong on this.
    But for all intensive purposes, I believe you don’t need to edit.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • https://wiki.archlinux.org/index.php/kernel_mode_setting#Early_KMS_start

    So it can make a difference…

    [updates once a week] = [90% less problems]
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    help development: donate antergos

  • Added this one too. It actually slightly helps, but overall visual experience is not flicker-free so far. Oh well, probably still better than having MS spyware bundled with OS.

  • @toxpal said in Video Drivers Problem?:

    Thanks guys, that’s a lot of information to read… Took me some time…

    @modisc said in Video Drivers Problem?:

    for flickering issue only:
    cat /etc/mkinitcpio.conf
    do you have this: MODULES=(… i915 …)

    While I don’t have this entry in specified file, instructions in other sources suggest that i915 is actually loaded on my system. For example - https://carlosbecker.com/posts/how-to-enable-kms-on-i915-graphiccard-archlinux/

    cat /sys/module/i915/parameters/modeset returns 1 for me, /etc/modprobe.d/i915.conf also has entry options i915 modeset=1 and so on. Do I still need to edit mkinitcpio.conf in this case?

    HI. No, you don’t

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

drivers48 video35 Posts 13Views 869
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.