• Failed to Start Light Display Manager


    After updating and later starting the system it won’t boot anymore with “Failed to Start Light Display Manager” - systemctl status reports the same error message, with “Failed with result ‘exit-code’” and “status=1/failure”, but no other error messages, journalctl has no error messages at all only a ton of “the start-up result is RESULT.”. I tried some solutions offered in the forum like enabling, disabling lightdm, reinstalling it, nothing of that seemed to work, is there anything else I could/should try or could find an error message in?

  • Take a look at /var/log/lightdm/lightdm.log
    I think that one usually has some error messages that can be useful. At least someone on IRC have found some gold in there then having issues :P

    I don’t use lightdm though so not sure if there’s anything new going on.

  • @tiedemann ok so it contains:

    [LightDM] contains unknown option session-manager
    

    right after loading the lightdm.conf

    and

    Failed to find session configuration slick-greeter
    
  • @clowntie Can you just paste the whole thing on https://paste.ee/ or some other place?

  • @tiedemann

    [+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
    [+0.00s] DEBUG: Starting Light Display Manager 1.26.0, UID=0 PID=724
    [+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
    [+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
    [+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
    [+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
    [+0.00s] DEBUG:   [LightDM] contains unknown option session-wrapper
    [+0.00s] DEBUG: Registered seat module local
    [+0.00s] DEBUG: Registered seat module xremote
    [+0.00s] DEBUG: Registered seat module unity
    [+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
    [+0.01s] DEBUG: Monitoring logind for seats
    [+0.01s] DEBUG: New seat added from logind: seat0
    [+0.01s] DEBUG: Seat seat0: Loading properties from config section Seat:*
    [+0.01s] DEBUG: Seat seat0: Starting
    [+0.01s] DEBUG: Seat seat0: Creating greeter session
    [+0.01s] DEBUG: Seat seat0: Failed to find session configuration slick-greeter
    [+0.01s] DEBUG: Seat seat0: Failed to create greeter session
    [+0.01s] DEBUG: Failed to start seat: seat0
    
  • Check the /etc/lightdm/lightdm.conf. It should contain a line what defines the theme it should use.
    Mine is default so it has:

    greeter-session=lightdm-webkit2-greeter
    
  • @tiedemann probably setting that to the default one will work again, but why did slick-greeter break? and I can’t reinstall slick-greeter because then it says dependencies break for itself

    @joekamprad do you have any issues too? since I remember you said you use slick-greeter too?

  • Try changing the line in /etc/lightdm/lightdm.conf to read:

    greeter-session=lightdm-slick-greeter
    

    For some reason, this change is necessary after the latest update to slick-greeter.

  • @grenouille Thanks, that was it, they probably finally renamed the actual package to be the same as the one in the repo

  • @grenouille said in Failed to Start Light Display Manager:

    lightdm-slick-greeter

    they only change the name of the session from slick-greeter to lightdm-slick-greeter
    here it works with changing this inside lightdm.conf like @grenouille say before.

    @ClownTie your log shows:
    [+0.00s] DEBUG: [LightDM] contains unknown option session-wrapper

    should be this:

    session-wrapper=/etc/lightdm/Xsession

    may you change wrong line?

  • @joekamprad I changed the slick-greeter name and it works again, should I still look into session-wrapper?

  • @clowntie you can check the entry inside lightdm.conf:

    cat /etc/lightdm/lightdm.conf | grep session-wrapper

    it should give out this:

    session-wrapper=/etc/lightdm/Xsession

  • @joekamprad yes it is set to that

  • i get also some debugging errors here may there are some options not needed anymore or not used anymore as leftovers inside config (lightdm.conf) i have also session-wrapper=/etc/lightdm/Xsession two times inside…

    And no issue at all on using it…

  • @joekamprad so I guess nothing to worry about then?

manager70 display48 light16 Posts 17Views 1685
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.