• AntergosPrime Display Server Not Starting


    Hey everyone,

    I’m new to Antergos and still kind of new to the Arch world, having moved over from Linux Mint recently. I’m trying to get AntergosPrime running correctly on my Optimus laptop, but I’m running into issues when trying to switch to the Nvidia graphics. Basically, I can run prime-select nvidia and everything goes smoothly. However, when I try to reboot I get to the part where the display manager (which is SDDM) tries to load and the blinking cursor starts blinking very fast. If I try to switch to another tty, the display blinks very quickly between the new tty and the original screen, and I can’t consistently type in the tty. This forces me to boot back into the live USB to chroot in and prime-select intel, which allows me to boot fine again. I’ve checked the journalctl for that boot, and it looks like the display manager is stuck in a loop of starting and stopping over and over. I’ve tried a few fixes for other issues I’ve found on this forum, hoping they would help, but no luck. I know I’m probably leaving useful info out, so please let me know any other info you might need. My computer is:

    Lenovo ThinkPad T530
    i5 3210M
    NVIDIA GF108M [NVS 5400M]

  • That is the program I am currently trying to use, but I am getting the problem I described. I have tried installing it from the GitHub page as well as the version in the Arch repos, with the same result.

  • Here is my full journal log.

    I tried editing my original post with this, but it keeps thinking it is spam.

  • Jun 28 12:06:19 Rex kernel: NVRM: The NVIDIA NVS 5400M GPU installed in this system is
                                NVRM:  supported through the NVIDIA 390.xx Legacy drivers. Please
                                NVRM:  visit http://www.nvidia.com/object/unix.html for more
                                NVRM:  information.  The 396.24 NVIDIA driver will ignore
                                NVRM:  this GPU.  Continuing probe...
    

    NVIDIA 390.xx Legacy drivers:
    https://antergos.com/wiki/hardware/graphics/antergos-nvidia-installer-2/
    read here about legacy drivers.

    you need to use nvidia-390xx driver and not latest nvidia.

  • spam protection nowadays needs to be strong, but after some reputation you do not have this anymore.

  • Awesome thanks for pointing that out! I was able to get it working after looking at the AntergosPrime script again. I finally realized that the script simply installs the NVIDIA utils packages, but doesn’t actually install the driver itself. So, I ended up installing the 390xx driver like you suggested, then editing the script to install/uninstall the 390xx utils when switching. That one was my fault for not realizing, but thank you so much for your help! Everything is working wonderfully!

  • this is the magic of linux and human readable logs ;)
    and nice from nvidia to give a very clear error message.

display50 starting23 antergosprime2 Posts 8Views 327
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.