• DOXBox is unable to capture mouse only on Antergos.


    It has been a few months since I’ve had to use DOSBox to run Windows 3.11, but coming back to it on three of my PCs I have noticed that DOSBox is unable to grab the mouse. It does make an attempt at it since I can click the mouse while moving it over a DOSBox window and it will register for a split second and move the mouse pointer, but that is about it. I’ve tried it with a clean install of Antergos on bare metal, VBox, and then tried DOSBox under a different distro. I’ve successfully gotten it to work under vanilla Arch and Ubuntu. Has anyone else had this issue?

  • @8bitsloth said in DOXBox is unable to capture mouse only on Antergos.:

    I’ve successfully gotten it to work under vanilla Arch

    We do not provide a special config for DOSBox, so it must be something else that is interfering with it. Are you using a touchpad or a standard usb mouse? Do you have tested the same desktop environment?

  • @karasu I’ve tested in Flux, Openbox, WindowMaker, XFCE, and KDE. DOSBox did not work correctly under any of them on Antergos. On non-Arch systems I’ve tested Unity, Openbox, and KDE. Even with a completely fresh install this happens only on Antergos on XFCE, Openbox, and KDE (I’m going to assume all other enviroments too). The DOSBox logs are useless for this issue and I’ve not been able to find a way to catch mouse events in X that would tell me why clicking on the DOSBox window or hitting CTRL-F10 is not capturing the mouse. I have Corsair M65 pro and it has worked up until recently. Sorry I do not have a precise date of when it started to fail, but I bought a DOS PC recently and had shifted my focus to that for a few months.

  • I found a post on the issue FINALLY: https://bbs.archlinux.org/viewtopic.php?id=237587

    Sure enough, updating my Xorg on vanilla Arch killed DOSBox. It seems the Xorg devs are jelly of DOS’ simplicity.

  • do you try LTS Kernel already? i have kind of the same issue inside virtualbox, booting with LTS Kernel solve the issue.

mouse62 unable62 capture3 doxbox1 Posts 5Views 598
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.