• Pamac and Skipping Package Updates


    Hello,

    Due to keyboard issues that I know are present with linux 4.17-2 (shipped by Arch upstream), I am trying to apply a partial update to my system.

    Using Pamac, I would graphically uncheck the packages and click apply. However, when I do this… it will apply the updates anyways (looking at the output that says “Starting Full System Update”), completely ignoring the fact that I had unchecked a few packages that I did not want to update.

    Is this a bug?

  • @stefanoume12 said in Pamac and Skipping Package Updates:

    Is this a bug?

    Maybe, i don’t use pamac for updagrading the system.

    One thing you can do is to manually add the package to be ignored to /etc/pacman.conf:
    Right after the line

    # Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup

    Add something like:
    IgnorePkg = granite linux linux-headers vhba-module

    OBS: that’s just an example.

  • @stefanoume12

    Hello

    Have you tried setting these packages as ignored in Pamac?

    Open Pamac, then preferences (3 dots, top right corner)
    Enter your password, when requested
    Under General tab, go to box at bottom
    Click ‘+’ to add packages to ignored list
    Dialogue box opens with list of all packages
    Select packages to ignore, click on ‘Choose’
    Ignored packages should now be listed on ‘General’ tab of Preferences

    This has worked for me in the past when an updated package has caused problems

  • @stefanoume12

    • partial updates are not supported by Archlinux and Antergos.

    So the only way is to put the packages you do not want to upgrade to the ignore list, inside pamac ( graphical package manager) or inside pacman.conf.

pamac65 updates59 skipping2 Posts 4Views 334
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.