• GNOME broken this morning


    I update a couple times a week but I rarely restart my system. Today was one of those rare moments. Lightdm took forever to load, and then once it did GNOME also tools long time loading. Once it finally did my autostart programs, Firefox, evolution, transmission, and steam for my steam controller started without a top bar and the dash to dock was missing along with the panel. I can not minimize applications or open new ones. It is like my whole desktop is missing. I control things mostly with s steam controller and use this as a htpc mostly so I miss my desktop. I can ctl alt f2 to commandline, but, the fixes I found on the archwiki did not work and I don’t want to start randomly killing extensions if this is a known problem about to be addressed.

  • @michaelnothing
    Could you try GDM instead LightDM?
    Login with your normal account on TTY console with Ctrl + Alt +F2

    sudo pamac -S gdm
    sudo systemctl disable lightdm
    sudo systemctl enable gdm
    
  • i’m having this issue (or similar) for a few days… i finally went with the nuclear option and reformatted everything. But the issue(s) prevails. I can’t cycle threw open applications, buttons don’t work, can’t minimize applications, pamac wont work (authentication dialogue fails to appear), can’t use dash without closing all applications or open applications form shortcut bar, can’t use any text dialogue field in any application… it looks like the shell or GTK is absolutely broken

  • @Edwin-Foss i was using GDM and i was having the same problem (or i think i’m having the same problem)

    Meanwhile i used the gnome tweak tool and disabled extensions globally (the top button). I tried to restart the shell (alt+f2 => r) with no results, but rebooted and i think it worked. Then i re-enabled extensions and rebooted and everything looks like its working now, thou i still don’t trust the system for stability. I suspect some broken extension was forcing to be loaded…

  • Gdm won’t load up at all. It fails twice on Authorization Manager, then starts Accounts Service and stalls out giving a blinking cursor.

    Downloading the latest install media from my laptop. I don’t know that it is a broken extension as I am pretty sure both computers are set up the same.

  • Wayland or X?
    There is a file that you can disable Wayland, so we can narrow which one is broken
    Login in TTY console then

    sudo nano /etc/gdm/custom.conf
    

    remove the hashtag symbol from

    #WaylandEnable=false
    

    Save the file (Ctrl+O), then restart the system

  • I needed the desktop back so I just reinstalled keeping my home and data folder and everything is okay now. For the record I use Wayland.

  • can this be related to the recent nvidia issues? i’m asking because none of my other Antergos machines, that don’t have nvidia, diden’t had any of this kind of issues…

  • @quimkaos said in GNOME broken this morning:

    can this be related to the recent nvidia issues? i’m asking because none of my other Antergos machines, that don’t have nvidia, diden’t had any of this kind of issues…

    Me too 😁

    @michaelnothing said in GNOME broken this morning:

    I needed the desktop back so I just reinstalled keeping my home and data folder and everything is okay now. For the record I use Wayland.

    Which graphics card is yours?

    If Nvidia I tried last year run wayland with nouveau but there is a lots of instabilities I would rather use nvidia with Xorg.

    😂 As I am a free/libre open source lover I ditched my last nvidia card, I couldn’t stand with all their policies, closing more and more, they can be superior in “horsepower” but it seems that they don’t take linuxers seriously, BTW Intel and AMD now is more friendly than ever and possibly 2019 we will see some better graphics card from Intel 😱

  • My problem persists … gnome ends being unusable… at this point i don’t know what can i do…

    @Edwin-Foss thou i hope Intel enters the discrete video card market, i doubt they pull a competitive one of they rear ends. BTW i think they already failed at that, 2 or 3 times. And… the Intel computex panic demo made me think 30 times before buying anything from them again. Then i’ll probably will not buy any nvidia card anymore, and that will leave me with little to choose from.

  • Gnome is completely broken and unusable, here are my logs:

    https://pastebin.com/vqna6tLh

    I’m getting tired of this and, sadly, thinking of moving from Antergos for the first time in 5 years. Any help is greatly appreciated.

  • @quimkaos
    i see you posted the same thing in arch forums with no help. it’s not an antergos issue so leaving will solve nothing. it’s these developers upspewing new protocols for pulseaudio, xorg-server, nvidia. last time i checked i have a few .pacnew files some of them critical so i dare not combine .pacnew with existing configs UNLESS i have a good Timeshift backup. linux mint so far is only one that ships with Timeshift in live usb which i have restored my arch linux at least 10 times this last month when xorg-server 1.20 failed, then when pulseaudio 12 ruined my ladspa (still haven’t fixed that) and a whole lot of other issues. i can’t fix your troubles, but if you manage to get out of this, install Timeshift it’s a lifesaver. antergos should have this by default

  • Thing is that i can’t have more than one window open or the shell gets unusable and i can’t get any work done. I don’t mind reinstalling the system, it takes 20 mn and i have a good backup policy.

  • @quimkaos You and your logs don’t describe your rig, debugging software without hardware it’s almost impossible tell us what cpu, ram and graphics card please.

    Sometimes the problem is hidden in something else, like yesterday, my wife ancient PC had a crash with openSUSE Tumbleweed software updater and gnome with xorg with discret radeon graphics stopped work giving garbled graphics and constant freezing falling back to gdm, the system was usable with wayland but had no video acceleration in browser, so, no way to watch youtube and similars, having that I convinced her to move to same distro as me turning my work more simple but after installing Antergos I got similar behaviour then I took about 2 hours to discover that the xf86-video-ati was the culprit, removing it was my solution but I installed xf86-video-amdgpu as backup since there is no full documentation where one begins and ends when radeon driver is on, the only thing that I really know is that ati driver carries microcodes which I suppose that the compatible ones overwrites same address space causing the graphics card ring 0 to stall.
    Well, as I said software depends on hardware, having that in mind dmesg and journalctl outputs can help to find the root of problem, so, more information here and more heads to think we can figure out together.

  • @Edwin-Foss sory i thought that it was understood that i had an nvidia card that uses the 340xx driver
    This is an Core2Duo E8500 @3.16Ghz with 4GB Ram and a Geforce 9600GT
    The issue started with the update of Xorg to version 1.2 and nvidia drivers, that i “solved” starting using the nouveau drivers:
    https://forum.antergos.com/topic/9919/xorg-server-update-causes-issues-with-nvidia-propritary-drivers
    Then nvidia drivers got updated and everything looked it was working, but then the shell started getting unstable down to unusable. I ended doing a clean install with no improvements, using either nvidia or nouveau drivers.
    I ended moving this machine to Manjaro, and there i noticed that Xorg never got update to version 1.2.
    So my advice is, if you are having similar issues, try downgrading Xorg to a version below 1.2.

  • @quimkaos do you try what i do for xfce?

    just use modesetting driver from kernel, and uninstall xf86-video-nouveau

    https://antergos.com/wiki/desktops/xfce/getting-xfce4-tearfree-with-nouveau-on-nvidia-graphics/

    But do not install compton as GNOME is not able to use it ;)

  • I diden’t…
    so basically :
    sudo pacman -R xf86-video-nouveau
    and edit /etc/mkinitcpio.conf
    ?

  • exact +

    sudo mkinitcpio -p linux to regenerate the images.

    It gives me much better performance, then with the driver package installed…
    But i do not test this under GNOME…

  • i’m enjoying Manjaro, but i think i’m going to try it

  • wow it looks like it’s working!! TY @joekamprad
    (well, lets see what tomorrow brings)

gnome327 Posts 24Views 1537
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.