• Strange mouse behavior after update


    I just want to report my issue and the solution I found so far for others, who may have the same issue, because I couldn’t find anything in the forums.

    I’m running Antergos with Xfce as guest in a virtualbox on Windows 7 Pro.

    Issue:
    Some days ago after an update I couldn’t use my mouse properly anymore. After starting Antergos the mouse worked as expected for a short time but soon after an application was started (like Firefox) I could move the mouse around, but the window did not recognize it. For example I could not close the window with the icon in the upper right corner, because the icon did not become active when the mouse pointer was over it. I couldn’t open menus etc. By accident I found that a window covered by the Firefox-window was active and reacted to the left click with my mouse. It was a thunar window. But the mouse wasn’t working with the thunar window in the foreground, as it was with all other applications. I also found that if I had only open terminal windows it took quiet a while until they didn’t respond to the mouse. But most of the time I could open menus with the mouse and after opening a menu I could drag the window around and close it by clicking the icon in the upper right corner again. When I let the system and the screensaver was invoked, the mouse did not work at all when I came back.

    Fixing the issue so far:
    I first thought this behavior had something to do xfce or the xorg-server* and downgraded them from my local cache to a version prior this strange behavior happened. But this didn’t help. Then I tried the “advanced boot options” when Antergos is starting. “Linux fallback” did not help, but choosing “Linus LTS” let the mouse work as before. So I knew it has something to do with linux. I downgraded the packages linux and linux-headers from 4.17.2-1 to 4.16.13-2. Now the mouse works fine again.

    For downgrading I used the downgrade script from the antergos repository.

    I’m willing to support anybody who wants to fix this issue, since downgrading doesn’t seem a sustainable solution to me .

    rob

  • @robma said in Strange mouse behavior after update:

    but choosing “Linus LTS” let the mouse work as before

    Correct!

    Also logout and relogin (vanilla kernel) makes it work again untill next reboot.

  • Thanks for this info, I had the same issue. I am running with gnome in Virtualbox under Windows 10. The kernel downgrade worked for me also. I presume this behavior will persist until a kernel is released that fixes the bug.

mouse62 strange16 behavior7 Posts 3Views 380
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.