• Samba - /usr/etc is not the correct path for samba's "options" file


    Hey guys.

    The samba package, since the 4.8.x series, seems to have a brewing mistake.

    Upon install/upgrade it creates /usr/etc/samba/sysconfig/samba which is the totally wrong directory path and spot for the file in question … /etc/conf.d would be more appropriate, given there’s already a “samba” options file from a previous version.

    Thanks for looking into it / correcting the recipe. ;)

  • @phunk-n-further said in Samba - /usr/etc is not the correct path for samba's "options" file:

    /usr/etc/samba/sysconfig/samba

    but as /etc/conf.d/samba is also created by latest samba package, it is may created by reason?
    and where is a “leftover” config file from previous version ?

  • Thanks for the link @joekamprad

    Didn’t really occur to me to go and look at what Arch did.

    usr/etc/
    usr/etc/sysconfig/
    usr/etc/sysconfig/samba
    

    (yes, I made a typo in my OP regarding the path/file)

    Alright, so it’s Arch themselves who seem to have introduced the issue. Well, nevermind then. I’ll simply deal with it myself and devise a “automated deletion” to keep the place nice and tidy.

  • i think that it is there for a reason, but hard to get a info why on arch wiki as it say nothing about this path…

  • The /usr/etc/sysconfig/samba file is identical to the /etc/conf.d/samba file. So my guess is that it’s a backup file in case you want to revert back to default config.

  • Or it is indeed something that went wrong packaging it. Who knows :)

    (sorry for 2 posts in a row, but I can’t edit my posts for some reason).

  • @joekamprad It’s very likely a packaging error or at least an artifact from the build process, unless the LSB has been changed (/etc suddenly relocated into /usr/etc) without anyone noticing.

    It’s not really a bug , it’s just a slight inconvenience which can be easily rectified by adding a “fix-ups” script into the boot-process to do some house-keeping.

    I just thought the Antergos packagers could cast some magic to counteract the mistake, that’s all.

    I’d file a report with Arch, but last time I checked they don’t take reports from users not running their proper OS very kindly.

  • Archlinux do not support other then pure archlinux yes.
    And samba from archlinux repositories.
    So we can not change this.
    But if it is a failure they will solve this on archlinux.

  • I asked in the arch channel on irc (yeah, I have another pure archlinux box with samba too), and the response was that it probably is a packaging error. They seemed to think usr/etc sounded a bit strange. So probably a prefix=/usr that have been misplaced somewhere in the build process.

  • so hopefully it will be fixed into the next update ;)

  • Yeah, maybe. I opened a bug report with Arch, set it to the lowest priority possible since it doesn’t actually break anything, it’s just a bit strange.

  • The samba package has now been updated by the packager in the arch repo. It was just a couple of lines that was missing in the PKGBUILD for the package, but now it shouldn’t contain these files in /usr/etc anymore.

  • @searedvandal said in Samba - /usr/etc is not the correct path for samba's "options" file:

    /usr/etc/sysconfig/samba

    ls  /usr/etc/     
    ls: cannot access '/usr/etc/': No such file or directory
    
error311 samba35 package6 Posts 14Views 397
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.