• Bugs in System Settings


    I noticed multiple bugs in KDE System Settings. Not sure if they are KDE-related, Arch-related or antergos-related. But here’s the list:

    1. Installed Evolution and uninstalled it shortly. Since then, clicking any mailto: link displays a pop-up error - Evolution not found. And then some other popup about KIO or KIOExec error. Of course, tried to change default mail client using Default Applications > Email Client tab, but no effect. No matter if I choose option “Use Kmail” or “Use a different email client” and enter it here, the same errors about Evolution missing were displayed all the time. The only way I could fix it - locate mimetypes.list file and manually edit it. There was an entry for x-scheme-handler/mailto set to Evolution, which I changed to claws-mail.desktop and it started working fine. For the record, my current setting in System Settings > Default Applications is set to KMail (which isn’t even installed), but Claws Mail is opened after clicking any mailto link. In other words, KDE settings have no effect.

    2. Similar issue for Default Applications > Web Browser. I selected option “in the following application” (and selected Vivaldi) for open http and https URLs setting, but it had no effect. Every time I clicked a link in some desktop app (email client, text editor, etc.) it opened BlueFish text editor which then displayed the source code of requested page. I realized that as soon as System Settings is closed, open http and https URLs setting reverts back to “in an application based on the contents of URL” and for some reason it executed BlueFish. I could partially fix it by choosing “with the following command” option and entering vivaldi-stable. Interesting, once System Settings is closed, selected option automatically changes to “in the following application” and Vivaldi is displayed then. Well, at least URLs are now opened with Vivaldi…

    3. Account Details > User Manager tab can’t enable auto login. I select my user (I’m the only user), select Log in automatically and password prompt appears. I enter my password and Log in automatically is checked. Once I close System Settings (or even jump to other tab in System Settings), the box becomes unchecked and auto login never works.

  • Loginmanager settings inside kde control center may only work for seem.

    For the default apps settings I remember some users have this before… may some other settings overwrite this settings… I will have a look to find related posts.

  • @toxpal
    Your bug with the emailclient had to do with Evolution, the app brings a lot of Gnome/GTK dependancies with and some of those remain there, even after removing Evolution. So it was those packages that keeps searching for Evolution, it even behaves like that in Gnome or any other DE.

    The setting you described in the second option, concerning Vivaldi IS the correct setting to make a browser the default one, not the first option. This sounds unlogical, I know, but it isn’t a bug, just the way KDE rolls.

    For your third option I have only one question: Are you using LightDm or sddm? Because KDE works better with sddm, especially the login features.

  • @bryanpwo said in Bugs in System Settings:

    Your bug with the emailclient had to do with Evolution, the app brings a lot of Gnome/GTK dependancies with and some of those remain there, even after removing Evolution. So it was those packages that keeps searching for Evolution, it even behaves like that in Gnome or any other DE.

    I had the same idea, so I searched for text “Evolution” inside all the files and removed it everywhere I could find. Especially in mimetypes.list file. However, the main problem is that OS doesn’t apply new settings. Like I said, no matter what I choose as default email client, system doesn’t update mimetypes.list. Even after I selected KMail as default client (all the references to Evolution are were removed manually), system didn’t make any changes to mimetypes.list. However, it properly makes changes to mimetypes.list when using File Associations tab. What makes to believe some part of settings manager is broken.

    @bryanpwo said in Bugs in System Settings:

    Are you using LightDm or sddm?

    I installed antergos KDE with default settings, so I guess my manager is LightDM?

  • I did install KDE a while ago and I’m using Thunderbird as the default email client. I never ran into that problem, but KDE did have a large update recently with some bugs in it, so this one could be one of them.

    If you install sddm your KDE expere=ience will be a more smooth sailing experience.
    Just install it and afterwards type in the terminal:

    sudo systemctl disable lightdm && sudo systemctl enable sddm
    

    Then reboot and sddm appears, if you then go to the systempreference and enable automatic login, it will be remembered.

  • Thanks, it worked.

    I also found that SDDM respects system settings and displays time in user-defined format at login window. I use 24 hours time format, and system used it properly, except login screen. It was always displayed as AM/PM, so I thought it’s the way antergos works (maybe it can only load user-defined settings after user is logged in), which I hated very much (but couldn’t find a way to fix).

    When using SDDM, user-defined format is used in login window as well, which is great.

    I think antergos developers could consider using SDDM as default manager at least for KDE edition. Did some search and found that KDE Plasma devs suggest using SDDM too. Just my 2 cents…

system126 bugs7 Posts 6Views 293
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.