• How to connect/access android smartphone via USB?


    Guys, I have been trying to access my Motorola MotoZ2 Play via USB to transfer some files to it, but I sucessfully failed completely in doing so. I installed mtpfs, kio-mtp and android-file-transfer, but all I get are error messages. Android-file.transfer gives me this message: “No MTP storage found, your device might be locked.
    Please unlock and press Retry to continue or Abort to exit.”.
    When I try to mount my phone via mtpfs -o allow_other ~/mnt, I get this output:
    Listing raw device(s)
    Device 0 (VID=22b8 and PID=2e76) is a Motorola Moto G (ID1).
    Found 1 device(s):
    Motorola: Moto G (ID1) (22b8:2e76) @ bus 1, dev 9
    Attempting to connect device
    error returned by libusb_claim_interface() = -6LIBMTP PANIC: Unable to initialize device
    Unable to open raw device 0
    When I try to open the phone in dolphin, it get an mtp protocol was terminated unexpectedly.
    Any ideas how to access my phone?
    J.

  • do you enable developer functions and enable usb-debugging inside this section?

    [updates once a week] = [90% less problems]
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    help development: donate antergos

  • @jeannie____
    Check

    • have gvfs-mtp installed
    • have MTP enabled on the phone

    and start a file manager.

    A tool for sending logs: https://forum.antergos.com/topic/10586/eat-logs
    Install eat: wget -q https://github.com/manuel-192/eat/raw/master/PKGBUILD && makepkg -sic

  • And possibly android-udev installed.

    A tool for sending logs: https://forum.antergos.com/topic/10586/eat-logs
    Install eat: wget -q https://github.com/manuel-192/eat/raw/master/PKGBUILD && makepkg -sic

  • Installing android-udev fixed it. Problem solved, thanks
    J.

usb99 android11 smartphone3 connectaccess1 Posts 5Views 557
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.