• Can't install DraftSight from AUR due to outdated dependency?


    I just tried to install DraftSight from the AUR. It fails because one of the dependencies is libmariadbclient-10.1.33-1-x86_64.pkg.tar.xz. When Build tries to download this package, it tries several repositories all reporting 404 not found. So I tried installing libmariadbclient-10.1.33-1 by itself, same thing 404 not found.

    So I did some checking around and the current version of libmariadbclient is 10.1.34-1 It looks like libmariadbclient has been updated and 10.1.33-1 has been removed from the repositories but DraftSight PKGBUILD and the libmariadbclient pkg have not been updated to reflect the update?

    How do I go about getting libmariadbclient updated? Do I have to go the Arch Linux and flag it or something like that?

    Thanks

    Pudge

  • If you can’t update to the current libmariadbclient because DraftSight depends on the older version, just uninstall DraftSight, upgrade libmariadbclient and reinstall DraftSight. In the dependencies for DraftSight it doesn’t specify any version number of libmariadbclient as far as I can see, so you should be able to reinstall it without any problems.

    Seared Vandal

  • @pudge said in Can't install DraftSight from AUR due to outdated dependency?:

    So I tried installing libmariadbclient-10.1.33-1 by itself, same thing 404 not found.

    I already tried that, but the libmariadbclient package in the extra repository is still 10.1.33-1 When I try to install libmariadbclient by itself in Antergos, it gives the following error:

    Error: failed retrieving file ‘libmariadbclient-10.1.33-1-x86_64.pkg.tar.xz’ from mirror.ams1.nl.leaseweb.net : The requested URL returned error: 404 Not Found

    So I believe that libmariadbclient was updated to 10.1.34-1 and 10.1.33-1 was removed from the extra repository.

    Pudge

  • https://www.archlinux.org/packages/extra/x86_64/libmariadbclient/

    It should be updated today to the current version. The mirror you’re using are probably just not fully up to date.

    Seared Vandal

  • @searedvandal said in Can't install DraftSight from AUR due to outdated dependency?:

    https://www.archlinux.org/packages/extra/x86_64/libmariadbclient/

    It should be updated today to the current version. The mirror you’re using are probably just not fully up to date.

    You’re correct, the you link provided shows 10.1.34-1 was last updated today
    Last Updated: 2018-06-20 07:45 UTC

    When it tried to download libmariadbclient, it tried SEVERAL repositories which all failed. So when I tried looks like none of the repositories was synced and that point.

    It looks like just bad timing on my part, yesterday or tomorrow it probably would have worked.

    Thanks searedvandal for your assistance. ☺

  • Or you can just grab it from the website (download from mirror) and upgrade it with pacman -U /path/to/package if that’s the only one you need upgraded that isn’t updated in mirror yet.

    Seared Vandal

  • @searedvandal said in Can't install DraftSight from AUR due to outdated dependency?:

    Or you can just grab it from the website (download from mirror) and upgrade it with pacman -U /path/to/package if that’s the only one you need upgraded that isn’t updated in mirror yet.

    Thanks. Joy at last. Finally got DraftSight to install on a Linux system. Drop down menus in the Linux version, which means FREEDOM from the RIBBONS on the Windows version.☺

aur52 due11 outdated3 draftsight2 Posts 7Views 176
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.