• Cnchi: Can't install openbox on virtualbox

    Hello I try to install Antergos on my virtual machine
    I downloaded the latest iso and started the installation.
    Everything worked fine until the very end of the installation.
    It say: “Can’t install necessary packages Cnchi can’t continue. Please reference the following number when reporting this error: None”. The installation work with Gnome. Definitely a problem with openbox package. And I can’t run “pacman -Syu” it say the partition is too full, the / partition is only 320Mb… Thanks for help

  • I saw a post saying to let the mirrors by default but of course if I do that it’s terribly slow. If there are a better mirror without corrupted packages it’ll be good…

  • I did a test of installing Antergos with Openbox in VirtualBox just now. It failed with the same error message.

    Here is the cnchi.log file: https://ptpb.pw/whVO

    I let Cnchi rank and choose mirrors.

  • I did some more testing, and I got it to install with some workarounds.

    After booting up the live usb, and letting Cnchi update itself (though I found it strange that it says it was up to date with 0.14.426 when 0.14.473 is the latest stable release on github) I closed Cnchi and fired up a terminal window.

    In the terminal I did the following command:

    sudo reflector -p https --save /etc/pacman.d/mirrorlist

    This generates a new filtered mirrorlist with https mirrors. I guess you could use http as well, but you have to specify one of the two since reflector includes rsync mirrors without the -p option.

    After that command I grabbed the PKGBUILD for reflector-antergos that @manuel made.

    wget https://raw.githubusercontent.com/manuel-192/antergos-reflector/master/PKGBUILD

    reflector-antergos depends on the time package, which you’ll have to install manually before building and installing reflector-antergos.

    sudo pacman -S time
    makepkg -i PKGBUILD

    After reflector-antergos is installed, we’ll let it generate a new antergos-mirrorlist.

    reflector-antergos --save

    Now we’re ready to open Cnchi again and continue with the install.
    At the screen where it asks you if you want Cnchi choose mirrors for you, you’ll choose the middle option that says let the mirrorlists be as they are now (default).

    Then it should be smooth sailing from there, at least it was for me. The install succeeded and I now have a brand new Antergos Openbox install on a VM. I did this testing in VirtualBox.

    I have no idea if there are any other options that don’t require as many steps, but this was the steps that worked for me today. Before I did all this I tried grabbing the 0.14.473 version of Cnchi manually off github and replacing all the files in /usr/share/cnchi with the newer ones. Cnchi executed with the new version, but failed at the same point again. That’s when I decided to try the reflector route to see if I had better success with that.

    Maybe worth a try for others having the same issue as well.

cnchi161 virtualbox47 openbox43 Posts 4Views 826
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.