• Libinput Gestures Broken - Version 1.11.1 Released Today


    Hey Guys,

    Libinput released an update today (1.11.1) , and it looks like it has broke my libinput gestures:

    Output:
    [[email protected] ~]$ libinput-gestures-setup start libinput-gestures started.

    [[email protected] ~]$ Command ‘[‘libinput’, ‘list-devices’]’ died with <Signals.SIGSEGV: 11>. Can not see any devices, did you add yourself to the input group and log out/in? Could not determine touchpad device.

    Anyone else seeing this issue? And if so, have found a solution?

    Thanks in advance, all your time and help is greatly appreciated!

    Thanks,
    Asif

  • So we are stuck until they fix the bug…good to know I guess.

  • @a4orce84
    AFAIK and unfortunately yes, unless someone has a workaround…

  • Does it make mouse to stop working?

  • By any chance have you run into the same problem I have @fernandomaroto? The one where you build an ISO and no matter what (for the past 5 or so days - which incidentally is, as far as I know, about the same amount of time that this libinput issue has surfaced for us) the majority of mouse clicks do not work in a VM? Because I’ve been running into that for days now! And while I could be mistaken, I strongly suspect that this is the cause. I know that libinput deals with the mouse and touchpad, although to the exact extent I am unsure of at this point. But it’s the only possible culprit I can find, so it’s the only thing I can think of that could be causing this issue.

  • @keegan said in Libinput Gestures Broken - Version 1.11.1 Released Today:

    By any chance have you run into the same problem I have @fernandomaroto? The one where you build an ISO and no matter what (for the past 5 or so days - which incidentally is, as far as I know, about the same amount of time that this libinput issue has surfaced for us) the majority of mouse clicks do not work in a VM? Because I’ve been running into that for days now! And while I could be mistaken, I strongly suspect that this is the cause. I know that libinput deals with the mouse and touchpad, although to the exact extent I am unsure of at this point. But it’s the only possible culprit I can find, so it’s the only thing I can think of that could be causing this issue.

    Yes, exactly that!!!
    My new isos have these bug and i’m like crazy trying to figure it out! hehehe
    So i’m “happy” that i’m not the only one. When i logout and relogin the mouse restarts working in VM, but i can’t find out why…

    I saw some xorg updates today, maybe they’ll fix it. (i didn’t see any libinput updates here yet)

    Are you also having errors like “old vboxsf binary” when booting the new iso?

  • @fernandomaroto said in Libinput Gestures Broken - Version 1.11.1 Released Today:

    My new isos have these bug and i’m like crazy trying to figure it out! hehehe

    Finally!!! I’m not the only one! I’m not going crazy 😄 . This issue has been driving me CRAZY!!!

    When i logout and relogin the mouse restarts working in VM, but i can’t find out why…

    Oooh… I didn’t notice that! Got to try it out here…

    I saw some xorg updates today, maybe they’ll fix it. (i didn’t see any libinput updates here yet)

    😄 Great minds think alike! I just started another new build here as well, hoping the same thing!

  • Are you also having errors like “old vboxsf binary” when booting the new iso?

    Yes! I’m SO glad to hear it’s not just me or something I am doing wrong

  • Perhaps we could downgrade a package for the ISO…

    We could compile an older version of this package and then tell build.sh to sudo pacman -U /into-the-iso or something like that. Maybe we could solve our issue that way until the problem is resolved for good…

  • @a4orce84 said in Libinput Gestures Broken - Version 1.11.1 Released Today:

    libinput

    libinput 1.11.1-2 is aviable as of now… and should include the fix…

  • Huzzah, I will install this as soon as I get back on my machine at home.

    Thanks @joekamprad! =)

  • @a4orce84 de nada ⌨ i get this news as a feed ;)

  • Mind sharing your setup, I’d love to get updates quickly and with some type of consistency.

  • @joekamprad said in Libinput Gestures Broken - Version 1.11.1 Released Today:

    @a4orce84 said in Libinput Gestures Broken - Version 1.11.1 Released Today:

    libinput

    libinput 1.11.1-2 is aviable as of now… and should include the fix…

    0_1529700684051_libinput.png

  • Ah that’s good, some mesa and radeon updates here too, i hope they fix some bugs i’m experiencig in my RM here as well.

  • https://www.archlinux.org/feeds/

    depending on your DE there are options to show rss feeds on the desktop or on bars…

    as i use i3 i have it in the blocks down at the bottom… for GNOME i do not know any good rss feeder as this one is stupid: https://extensions.gnome.org/extension/948/rss-feed/
    but once i try this news ticker app: https://www.omgubuntu.co.uk/2015/06/tickr-open-source-desktop-rss-news-ticker

  • Updated and we are back in business! Love libinputgestures! =)

    Thanks everyone for your time and help, it is SUPER appreciated!

    Thanks,
    Asif

  • @keegan

    The bug in virtualbox is kernel related, i booted the iso with latest kernel and mouse clicks don’t work exept after logout/relogin.

    If i boot the iso with LTS the iso works normally. So we’ll need to wait for a kernel update to release a new iso version.

broken33 libinput5 gestures4 1.11.11 Posts 21Views 1092
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.