• Bumblebee: Nvidia Card does not switch off after Xorg-Server 1.20

    Since the last Updates from the Xorg-Server 1.20 and the other updates from Nvidia Graphics, the Nvidia Graphics never switch off. They are always loaded.
    I already tried reinstalling with the Nvidia - Installer, and in Use are the Nvidia39x Drivers.
    Did someone had this problem in the last time?
    When I try optirun --status I always get, even after a reboot:
    Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is likely on.
    I tried switching off the Nvidia Graphics with the guide in the Wiki for bumblebee, but the command for unloading the modules sudo rmmod nvidia_drm nvidia_modeset nvidia
    always returns the error:

    rmmod: ERROR: Module nvidia_drm is not currently loaded
    rmmod: ERROR: Module nvidia is in use

    Had someone a similar problem before or knows how to solve it?
    I waited the last few days for the updates with the Kernel 4.17, but even after the update the Problem still persists.

    For some more information on my System:

    [[email protected] ~]$ inxi -Fz
    System:    Host: Antergos Kernel: 4.17.2-1-ARCH x86_64 bits: 64 Desktop: Gnome 3.28.2 
               Distro: Antergos Linux   ( ) 
    Machine:   Type: Laptop System: LENOVO product: 24476J7 v: ThinkPad W530 serial: <filter> 
               Mobo: LENOVO model: 24476J7 serial: <filter> UEFI [Legacy]: LENOVO 
               v: G5ET98WW (2.58 ) date: 04/01/2014 
    Battery:   ID-1: BAT0 charge: 66.0 Wh condition: 84.8/93.6 Wh (91%) 
    CPU:       Topology: Quad Core model: Intel Core i7-3740QM bits: 64 type: MT MCP 
               L2 cache: 6144 KiB 
               Speed: 3094 MHz min/max: 1200/3700 MHz Core speeds (MHz): 1: 3081 2: 2618 3: 3069 
               4: 3036 5: 2579 6: 3043 7: 3089 8: 2268 
    Graphics:  Card-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel 
               Card-2: NVIDIA GK107GLM [Quadro K2000M] driver: nvidia v: 396.24 
               Display: x11 server: X.Org 1.20.0 driver: intel resolution: 1920x1080~60Hz 
               OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 18.1.1 
    Audio:     Card-1: Intel 7 Series/C216 Family High Definition Audio driver: snd_hda_intel 
               Sound Server: ALSA v: k4.17.2-1-ARCH 
    Network:   Card-1: Intel 82579LM Gigabit Network Connection driver: e1000e 
               IF: enp0s25 state: down mac: <filter> 
               Card-2: Intel Centrino Ultimate-N 6300 driver: iwlwifi 
               IF: wlp3s0 state: up mac: <filter> 
    Drives:    HDD Total Size: 465.76 GiB used: 163.81 GiB (35.2%) 
               ID-1: /dev/sda vendor: Hitachi model: HGST HTS725050A7E630 size: 465.76 GiB 
    Partition: ID-1: / size: 46.68 GiB used: 25.36 GiB (54.3%) fs: ext4 dev: /dev/sda2 
               ID-2: /boot size: 1022.2 MiB used: 57.4 MiB (5.6%) fs: ext4 dev: /dev/sda1 
               ID-3: /home size: 406.53 GiB used: 138.40 GiB (34.0%) fs: ext4 dev: /dev/sda3 
               ID-4: swap-1 size: 3.89 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda5 
    Sensors:   System Temperatures: cpu: 53.0 C mobo: N/A 
               Fan Speeds (RPM): cpu: 1968 
    Info:      Processes: 268 Uptime: 25m Memory: 7.36 GiB used: 1.75 GiB (23.8%) Shell: bash 
               inxi: 3.0.12 
  • do you actually have the bumbleed service started? (note the d at the end of bumblebee which means its the service) I had problems myself until i switched to the bumblee-git package but I think your bumblee service isnt started.

  • Gah forgot i couldnt edit, the reason i switched to the git package of bumblebee is it had a bug fix i needed but wasnt a part of the official package.

  • also what is your boot flags for your kernel?

  • I never heard about a bumblebee git package, when I checked on github before once it looked kind of dead.

    I just checked the running services, but the active services show it as running:

    loaded active running   Bumblebee C Daemon

    So bumblebee itself should work I think.

    I never have changed the kernel boot parameter before. So I guess it should be standard. But the lines in my Grubconfig looks like this:

    # GRUB boot loader configuration
    GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=cab0a09c-b261-472c-baf4-1710a849e1ae"
nvidia166 bumblebee49 switch23 xorg-server3 Posts 5Views 424
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.