• CUPS - KIOExec Error


    Installed my printer (Brother HL-L2350DW) drivers along with CUPS. Printer added successfully and works.

    However, every time I click “Manage Printing (CUPS Web Interface)” in start menu, error is displayed:

    Error - KIOExec
    A folder named /home/myusername/.cache/kioexec/krun/3442_0 already exists

    Number (3442_0) is different every time, and this error comes even if I delete whole /kioexec directory before running CUPS. Searched the Internet for this error and found some complains, but they were related to different apps. That is to say, other people get this error with random apps - FireFox, Dolphin, etc. Some of them were solved by updating apps themselves. However, I have the latest version of CUPS, so there’s nothing to update.

    CUPS itself works if I type localhost:631 into browser, but entry in start menu always displays this error.

  • creat your own desktop file for it may works… as there is something misinterpreting, kioexec is to download remote files to temporary filesysten to open it as it was local… but cups webinterface is already local …

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Could you tell me if it’s normal that CUPS is only started after I manually start service via terminal or by printing some document?

    I mean, CUPS is enabled and started. But once system reboots, CUPS doesn’t auto start. Trying to get its status via systemctl displays enabled, inactive (dead). So if I want to open localhost:631, I must manually start CUPS service or print some document (clicking Print button starts CUPS service in background and it continues working then).

    Tried multiple re-installs and reboots - issue remains. While it’s not a big deal, it’s kinda annoying that in order to manage printer settings after reboot, it’s needed to print some page first.

  • @toxpal
    Don’t know if it is normal or not. Currently I cannot check my printer system either… sorry about that.

    But to get rid of the annoying part, why not write a two line wrapper bash script that:

    • starts CUPS service
    • manages printer settings

    🙂

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL here.

  • systemctl status org.cups.cupsd
    ● org.cups.cupsd.service - CUPS Scheduler
       Loaded: loaded (/usr/lib/systemd/system/org.cups.cupsd.service; enabled; vendor preset: disabled)
       Active: active (running) since Mon 2018-06-18 19:29:20 CEST; 23min ago
         Docs: man:cupsd(8)
     Main PID: 492 (cupsd)
       Status: "Scheduler is running..."
        Tasks: 2 (limit: 4915)
       Memory: 6.3M
       CGroup: /system.slice/org.cups.cupsd.service
               └─492 /usr/bin/cupsd -l
    
    Jun 18 19:29:19 empowered64 systemd[1]: Starting CUPS Scheduler...
    Jun 18 19:29:20 empowered64 systemd[1]: Started CUPS Scheduler.
    
    

    should run or do you have another service/socket running?

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • sudo systemctl enable org.cups.cupsd will enable it on boot

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @manuel said in CUPS - KIOExec Error:

    But to get rid of the annoying part, why not write a two line wrapper bash script that:

    starts CUPS service
    manages printer settings

    Well, I’m totally new in Linux world, but I guess it’s doable.

    However, my main interest would why it doesn’t work as expected on my system…

  • @joekamprad said in CUPS - KIOExec Error:

    sudo systemctl enable org.cups.cupsd will enable it on boot

    Yes, this is exactly what I did 4 times total. I run this command, it displays some success message (it creates 3 symlinks if I remember right), then I start service and it works… until reboot.

    Then doing systemctl status org.cups.cupsd brings:

    ● org.cups.cupsd.service - CUPS Scheduler
       Loaded: loaded (/usr/lib/systemd/system/org.cups.cupsd.service; enabled; vendor preset: disabled)
       Active: inactive (dead)
    

    Running systemctl start org.cups.cupsd starts it without a single error. As well as clicking Print button in any app.

  • @toxpal
    Maybe this helps? https://bbs.archlinux.org/viewtopic.php?id=216216
    Especially messages 8 and 10 seem interesting.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL here.

  • Thanks, will try!

  • printer is connected via usb or is it a wireless or wired network printer?

    as you may have the problem that cups is started before your system is cinnected to the network… so it do not see the printer… so may enable a helper service is needed…

    NetworkManager-wait-online.service

    cups-browsed.service

    Make remote CUPS printers available locally

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • It’s a wifi printer, which is “connected” (via wifi) to router.

  • sudo systemctl enable NetworkManager-wait-online.service
    
    sudo systemctl enable cups-browsed.service
    

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • and your device is a notebook connected via wifi to the router… so system boots without wifi and connects at the moment you login in the end

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • My system is a desktop PC, but yes, it’s connected via wifi.

    Anyhow, followed both of you (@manuel and @joekamprad) suggestions and it seems to work now. Performed 2 test reboots, CUPS is up and running every time.

    I guess I can live with KIOExec error now… 🙂

error285 cups18 kioexec1 Posts 15Views 366
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.