• Installing older version of Citrix


    I read https://forum.antergos.com/topic/2774/how-to-downgrade-a-package but didn’t quite understand if this is what I was looking for. Is it just as simple as replacing the 13.9 with 13.8 or .7? Is there a place I would look this up? Do I have to build my own package? Antergos is my first step into Arch so apologies for what may be a super simple question.

  • downgrading works only for packages inside the repositories, not for AUR builds, this ones are needs to build and not officially supported, as they are only provided from user to user…

  • @joekamprad thank you. So I also followed the Arch Wiki on Citrix https://wiki.archlinux.org/index.php/citrix, following these instructions seems to have worked but now I get an SSL error. The wiki states that c_hash is broken in arch but I don’t see a work around. I get the below error when I try to install the current package as well. I can’t find the c_rehash file. Any thoughts?

    Preparing…

    Building icaclient…
    Cloning into ‘icaclient’…
    remote: Counting objects: 117, done.
    remote: Compressing objects: 100% (62/62), done.
    remote: Total 117 (delta 55), reused 117 (delta 55)
    Receiving objects: 100% (117/117), 47.56 KiB | 477.00 KiB/s, done.
    Resolving deltas: 100% (55/55), done.
    ==> Making package: icaclient 13.10-1 (Fri 29 Jun 2018 09:26:45 AM EDT)
    ==> Checking runtime dependencies…
    ==> Checking buildtime dependencies…
    ==> Retrieving sources…
    -> Found configmgr.desktop
    -> Found conncenter.desktop
    -> Found selfservice.desktop
    -> Found wfica.desktop
    -> Found wfica.sh
    -> Found wfica_assoc.sh
    -> Downloading icaclient-x64-13.10.tar.gz…
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    100 19.2M 100 19.2M 0 0 5543k 0 0:00:03 0:00:03 --:–:-- 5541k
    ==> Validating source files with md5sums…
    configmgr.desktop … Passed
    conncenter.desktop … Passed
    selfservice.desktop … Passed
    wfica.desktop … Passed
    wfica.sh … Passed
    wfica_assoc.sh … Passed
    ==> Validating source_x86_64 files with sha256sums…
    icaclient-x64-13.10.tar.gz … Passed
    ==> Extracting sources…
    -> Extracting icaclient-x64-13.10.tar.gz with bsdtar
    ==> Entering fakeroot environment…
    ==> Starting package()…
    Unknown regexp modifier “/W” at /usr/bin/c_rehash line 28, at end of line
    Unknown regexp modifier “/3” at /usr/bin/c_rehash line 28, at end of line
    Unknown regexp modifier “/2” at /usr/bin/c_rehash line 28, at end of line
    No such class installdir at /usr/bin/c_rehash line 63, near “Prefix our installdir”
    (Might be a runaway multi-line // string starting on line 28)
    syntax error at /usr/bin/c_rehash line 63, near “Prefix our installdir”
    Can’t redeclare “my” in “my” at /usr/bin/c_rehash line 68, near “my”
    Execution of /usr/bin/c_rehash aborted due to compilation errors.
    ==> ERROR: A failure occurred in package().
    Aborting…

  • @jco42 said in Installing older version of Citrix:

    (Might be a runaway multi-line // string starting on line 28)
    Can’t redeclare “my” in “my” at /usr/bin/c_rehash line 68, near “my”

    this is the most funny error message i ever read ;)

  • @joekamprad said in Installing older version of Citrix:

    this is the most funny error message i ever read ;)

    good, I’m glad it’s unique. It makes me feel better that google searches were coming up empty

  • do you check build dependencies?

  • @joekamprad no i haven’t or maybe not the right way. i’m looking at pacman -Qi or -Si but those don’t seem to do what you’re asking. what should i be searching for?

  • @jco42 said in Installing older version of Citrix:

    c_rehash

    pacman -Qo c_rehash
    /usr/bin/c_rehash is owned by openssl 1.1.0.h-1
    
  • @joekamprad ty

    /usr/bin/c_rehash is owned by openssl 1.1.0.h-1, which makes sense with what i saw on the arch wiki

    @jco42 said in Installing older version of Citrix:

    @joekamprad thank you. So I also followed the Arch Wiki on Citrix https://wiki.archlinux.org/index.php/citrix, following these instructions seems to have worked but now I get an SSL error. The wiki states that c_hash is broken in arch but I don’t see a work around. I get the below error when I try to install the current package as well. I can’t find the c_rehash file. Any thoughts?

    So can i uninstall 1.1.0 and use 1.0.2?

  • 0_1530348040358_Bildschirmfoto_2018-06-30_10-40-09.png

    they can coexist. I have them both installed, as i think it would brake the system to uninstall v1.1

  • any other ideas? i’m also wondering if there is not something more going on with my system as i can’t even install another OS. The box itself is about 8yrs old, the hard drives are about 4. It may just be time.

installing111 older3 citrix1 Posts 11Views 381
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.