• Antergos Installer error at Checking integrity


    Hello,

    I have a problem while installation of antergos.

    “Can’t install necessary packages. Cnchi can’t continue”

    after running command

    cat /tmp/cnchi.log | curl -F [email protected] https://ptpb.pw/?u=1
    
    

    Here is log
    log

  • @arsahadali4
    That was an old issue and should have been fixed. But it seems that in the beginning, cnchi cannot update itself, as it automatically should.

    So maybe it was a temporary problem, can you try again?

  • @manuel said in Antergos Installer error at Checking integrity:

    can you try again?

    So i have to start my installation again?

  • @arsahadali4
    Yes, if you wish to install Antergos. 😎

  • @manuel
    It was my second try.
    can you shoot precautions for starting again?

  • @manuel
    again showing the same error :(

    “Can’t install necessary packages. Cnchi can’t continue”

  • @arsahadali4

    • download latest Antergos installer ISO (antergos-18.6-x86_64.iso) from antergos.com (if not already done)
    • burn the ISO to USB with Etcher or dd
    • check internet connection right after booting the USB stick (start terminal)
    ping -c 10 www.antergos.com
    
    • let cnchi select mirrors
    • or, select mirrors manually

    These are the most obvious things.

  • @manuel said in Antergos Installer error at Checking integrity:

    cnchi cannot update itself, as it automatically should.

    This is a leftover error message from a unused script what is no longer used… so it is not say the truth ;)

  • @joekamprad
    Then hopefully @developers remove that misleading message…

  • @joekamprad
    already followed the above steps but problem is its failing at integrity
    right after downloading everything.

    cnchi cannot update itself, as it automatically should.

    This last time I updated it manually.

  • @arsahadali4
    @joekamprad
    Is this a keyring issue? If so, maybe @developers have some insight?

  • @manuel said in Antergos Installer error at Checking integrity:

    BTW is there any way to skip /boot/efi
    I don’t need it at all

  • @arsahadali4
    Depends on many things. An EFI partition (or sometimes called as ESP) is a boot partition for UEFI booting for any operating system. Typically the partition exists because Windows uses it. It is a small partition (usually less than 200MB).

    But if you have only Antergos on the machine, and the machine supports BIOS legacy booting, then you can just remove that partition with e.g. gparted.
    Then install Antergos using BIOS legacy booting, and write MBR to /dev/sda.
    Note that the disk should have the msdos partition table, not gpt.

  • antergos-openbox … i try yesterday and it was failing at my try on VM also !! but as i was on try out some encryption stuff i do not mind and change to XFCE…

    Problem is that cnchi.log do not say what package was failing… this you can find inside cnchi-alpm.log only… @karasu say that this two ones should be merged for more easy investigation…

  • 2018-06-14 17:56:22 [DEBUG] pac.py(556) cb_log(): found cached pkg: /install/var/cache/pacman/pkg/openssh-7.7p1-1-x86_64.pkg.tar.xz
    2018-06-14 17:56:22 [DEBUG] pac.py(556) cb_log(): sha256sum: fdd14278c896aef9cbc08bca9bc266516e7daaae221da22a070f356cb12c93d9
    2018-06-14 17:56:22 [DEBUG] pac.py(556) cb_log(): checking sha256sum for /install/var/cache/pacman/pkg/openssh-7.7p1-1-x86_64.pkg.tar.xz
    2018-06-14 17:56:22 [DEBUG] pac.py(556) cb_log(): returning error 34 from check_validity : 
    Invalid or damaged package
    

    that’s a package from archlinux core repository… but it is taken from ISO cache… (as far as i understand… )

    Lovely @developers should take a look !

  • I am failed again, saydd life :( 5th/6th time

    Please @developers take a look.

  • if you wait for 10 minutes i may have a workaround…

  • i am not sure what is the cause… i get also:

    archlinux.us-east.mirror.zoidplex.net : SSL certificate problem: certificate has expired
    

    removed this server from mirrorlist and clean the pacman cache may help to get openbox installed…

    sudo pacman -Sc
    sudo pacman -Syy

    before starting install.

    I can report in around 15 minutes if it helps…

  • sorry no way to install it fails also with clean cache…
    Seems to be something broken on side of Archmirrors or a keyproblem in general…

error307 Posts 23Views 1166
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.