• \[Solved\]Switching from LightDM to gdm


    Hi,

    I’m new to Antergos and to this forum, coming from (and still mostly using) Debian.

    I’m using Gnome Shell and I’d like to switch to gdm as a display-manager, just to see how it works. I have no issues with lightDM and I like to artwork you did on lightDM. I just want to learn how to switch on an Arch-based system using systemd.

    I installed gdm

    sudo pacman -S gdm
    

    and then

    sudo systemctl enable gdm  
    Failed to execute operation: File exists
    

    What’s the reason for failure ? Where should I look for the reason. What information is needed ?

    Regards hias

    Old Desktop: Antergos (Gnome Shell)

    • other systems Debian
  • Hi,

    I’m new to Antergos and to this forum, coming from (and still mostly using) Debian.

    I’m using Gnome Shell and I’d like to switch to gdm as a display-manager, just to see how it works. I have no issues with lightDM and I like to artwork you did on lightDM. I just want to learn how to switch on an Arch-based system using systemd.

    I installed gdm

    sudo pacman -S gdm
    

    and then

    sudo systemctl enable gdm  
    Failed to execute operation: File exists
    

    What’s the reason for failure ? Where should I look for the reason. What information is needed ?

    Regards hias

    Old Desktop: Antergos (Gnome Shell)

    • other systems Debian
  • Hi,

    You have to disable lightdm first:

    sudo systemctl disable lightdm && sudo systemctl enable gdm
    

    Cheers!

  • Hi lot.0.logs,

    thanks for your quick answer. Works as it should.

    Thanks Hias

    Old Desktop: Antergos (Gnome Shell)

    • other systems Debian
  • @lots.0.logs said:

    sudo systemctl disable lightdm && sudo systemctl enable gdm

    I have done this, because I have problems with the lockscreen and I get gdm as login screen, but my login password does not work anymore. If I switch back to lightdm, my password works again.

    What is the solution for this password problem?

  • @BuZZ-dEE : If you installed GDM I will suppose you’re using Gnome, right?

    Check that in Gnome Settings you have your keyboard layout configured as it should.

  • @karasu said:

    @BuZZ-dEE : If you installed GDM I will suppose you’re using Gnome, right?

    Check that in Gnome Settings you have your keyboard layout configured as it should.

    Yes, I use GNOME. Before switching to GDM the layout is correct and after switching back to LightDM the layout is correct. You mean in GDM login screen? I looked in the toppanel for such an option, but didn’t saw it. For checking in " Gnome Settings" I need to logged in or where do you mean?

  • For checking in " Gnome Settings" I need to logged in or where do you mean?

    Yes, yes. I mean once logged, go to Gnome Settings and check that the correct layout is shown.

  • @karasu said:

    For checking in " Gnome Settings" I need to logged in or where do you mean?

    Yes, yes. I mean once logged, go to Gnome Settings and check that the correct layout is shown.

    How if I can not log in with GDM?

  • From a terminal console: (CTRL+ALT+F2):

    dbus-launch gsettings set org.gnome.desktop.input-sources sources "[('xkb','us')]"
    

    Obviously, you have to change us for your keyboard layout

    Cheers!

Posts 10Views 17051
Log in to reply