• Put HDD to sleep permanently


    Hello =)

    i got an laptop with two drives (ssd & hdd). Since I don’t need the HDD atm and it’s making quite some noise and vibrations, I want to put it in sleep mode (and also save some battery).

    Using hdparm i can do it manually, even using this ArchWIKI tip works fine and the drive spins off during boot.
    The problem is, as soon as i login (KDE) the drive spins up again and won’t go back to sleep - ever. I can’t figure out why and all tips i’ve found didn’t work (udev rules).

    it’s /dev/sda/ and not mounted nor partitioned

    Thanks for any help 👍

  • disconnecting it from power…

  • Thanks for your reply, that’s the last resort if there is really no other way.

  • @larafi
    But you can turn if off manually with hdparm, even after login? Didn’t quite get your logic fully I’m afraid…

  • yes, manually its working, but a bit annoying to do every reboot.

  • @larafi
    Does your system boot from the HDD?

  • I’m not using KDE, so don’t know its details. In Xfce there’s a GUI settings manager app that allows setting the session startup programs, probably KDE has something similar.

    But if you use a terminal frequently, you could put that hdparm command to your ~/.bashrc file.

  • Thanks a thousand times!
    I feel kind of stupid… it’s sooooo obvious. Using a startup programm/script works fine.

  • @larafi Maybe we all tend to think too complicated… Simple solutions are often the best. :)

sleep18 hdd11 permanently1 Posts 9Views 217
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.