• Nvidia-installer -b drivers prevent from booting


    I just installed nvidia-installer and I installed the drivers with no problems (with nvidia-installer -b because I have a dual GPU). My computer is a Dell Inspiron 5577 Gaming.

    So, back to the story. I reboot, as per the installer’s request and when I boot back in, I’m greeted with a PCIe Bus error saying severity=Corrected and layer=physical. The system seems to have difficulty after that - it does’nt stop doing anything, but there are multiple hangs reported.

    Any clues on how to solve this ?
    If you need more info, please let me know.


  • @fa-rouche
    Could you show a picture of the failing situation? You can do it e.g.

    cat "your-picture-file" | curl -F [email protected] https://ptpb.pw/?u=1

    and show the returned URL here.

    But can you press keys Ctrl-Alt-F2 and get into a (full screen) terminal?
    If so, there you can log in and try to revert the installation of graphics drivers.

    You could show what packages you have installed e.g. with commands:
    pacman -Qs nvidia
    pacman -Qs bumblebee
    pacman -Qs bbswitch
    pacman -Qs xf86-video

  • Another way to go to your system is booting with the USB installer stick.
    After booting, start a terminal window.
    Then find your root partition with command

    lsblk -fm

    It probably is the partition with “AntergosRoot” as a label. Note the /dev/sdXY on that line, you’ll use it later. The X refers to the disk letter, and Y is the partition number on the disk. If you have a separate boot partition, note that, too.

    Then you can go to your installed system:

    su  # get root permissions
    mount /dev/sdXY /mnt
    mount /dev/sdAB /mnt/boot  # optional, only if you have a separate boot partition
    arch-chroot /mnt

    Now you are in your installed system, and can make required driver changes.
    In the end, exit the chroot and umount the partitions:

    umount /mnt/boot
    umount /mnt
  • @fa-rouche said in Nvidia-installer -b drivers prevent from booting:

    Dell Inspiron 5577 Gaming

    Integrated Discrete
    Controller Intel HD Graphics 630 NVIDIA GeForce GTX 1050
    Memory Shared system memory 4 GB GDDR5

    should be a optimus aka bumblebee one, but i do not think that nvidia-installer -b will do the complete job to enable bumblebee on all kind of systems, so i would read here also:


  • Hi. Thanks for the replies. I’ll try each of your solutions, starting with @joekamprad 's since I reformatted my PC right after as I needed it for some other purpose. If it fails again, I’ll make sure to make the screenshot. When it happened I did not have access to another tty. It really just had too many hangs to handle anything else I guess.

  • Alright, so I reinstalled with the steps provided by the wiki that @joekamprad provided.

    That being said, I got the same error as before, which I have screenshotted.

    This is the error I get with no boot parameters :

    This is what I get with acpi_osi="!Windows 2015" as boot parameter proposed in the wiki:

    Adding the boot parameter acpi=off makes my system boot and brings me to the GUI but my keyboard and mouse don’t work at that point…

  • Okay. So after fiddling with a couple boot parameters I got to boot successfully with :
    acpi_osi=! acpi_osi=“Windows 2009”

    This is the only one that worked for me.

  • Thanks for the help. I tried editing but Antergos forum says I’m getting disconnected ??

  • @fa-rouche
    Forum has this known bug and some others, unfortunately. I just hope some day a new version of forum software could be installed…

  • @fa-rouche
    For the record, was this acpi_osi kernel boot parameter the only parameter you needed for proper booting? If not, could you please show the full list of additional kernel boot parameters you used? That might be useful for others with the same or similar machine.

  • here is what i have to use on my msi laptop, took me months to figure this out.

    modprobe.blacklist=nouveau acpi_osi=! acpi_osi='Windows 2009' nomodeset i915.modeset=1 

    i also add


    because of all the troubles i have had with nvidia drivers i now am paranoid and just boot to tty and use startx lol

  • @jardragon901 but what you wnt is to disble the discrete card complete? so you do not want to install nvidi driver and only run on the intel ?

  • so buggy ACPI stuff inside Bios/Firmware is the cause then…

  • No it disables the discrete card during boot but bumblebee is still able to start it to play games.

  • @joekamprad said in Nvidia-installer -b drivers prevent from booting:

    so buggy ACPI stuff inside Bios/Firmware is the cause then…

    It seems so yes.

drivers56 booting56 prevent7 Posts 15Views 604
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.