• lightdm show wallpaper from desktop


    i use cinnamon DE and in many arch based distro i use slick-greeter so i
    install from aur lightdm-slick-greeter change in /etc/lightdm/lightdm.conf from
    greeter-session=lightdm-webkit2-greeter to greeter-session=slick-greeter and i install lightdm-settings and here comes the problem.

    when i change the background in lightdm-settings to background from /usr/share/background/antergos when the lightdm starts i see my wallpaper only for 2-3 seconds after that wallpapers is change itself to wallpepers from my desktop. i dont know why ;/ i have first time this issue. i can attatch my lightdm.conf and log

    lightdm.conf

    lightdm.log

    x-0.log

  • i am using slick greeter also for long now and never have this here… but may it is related to cinnamon itself then…

    Your logs and config are the same like what i get here.

    Or do you have this only with this specific wallpaper folder?
    /usr/share/backgrounds/antergos

    [updates once a week] = [90% less problems]
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    help development: donate antergos

  • @joksik

    What does command

    ls -l /usr/share/backgrounds/
    

    show you?

    A tool for sending logs: https://forum.antergos.com/topic/10586/eat-logs
    Install eat: wget -q https://github.com/manuel-192/eat/raw/master/PKGBUILD && makepkg -sic

  • @manuel

    ls -l /usr/share/backgrounds/
    
    lrwxrwxrwx 1 root root   22 01-08 02:58 antergos -> ../antergos/wallpapers
    drwxr-xr-x 2 root root 3488 06-12 19:04 gnome
    
    

    @joekamprad i try many diffrents folders. the results always is the same. i see wallpapers what i set in lightdm-settings for few seconds after that wallpaper is change to wallpapers what i have on my desktop

  • this reminds me on a option from like: use wallpaper from user if aviable… but this is from lightdm-gtk-greeter ?

    [updates once a week] = [90% less problems]
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    help development: donate antergos

  • 0_1528836924813_IMG_20180612_225257.png

    [updates once a week] = [90% less problems]
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    help development: donate antergos

  • i check and i dont have installed lightdm-gtk-greeter

  • It’s a new feature of slick-greeter and it’s also a lightdm-settings bug as I reported here https://forum.antergos.com/topic/10083/missing-lightdm-settings-option.

    Just

    sudo nano /etc/lightdm/slick-greeter.conf
    

    Then add (or modify) at the end of the file :

    draw-user-backgrounds=false
    

    Should do the trick.

  • @papa33 thx !!! now everything’s work as it should 😉 i reported this bug on slick-greeter github page. maybe they fix lightdm-settings and add option to enable/disable this new feature

  • Good community work here 🙂

    [updates once a week] = [90% less problems]
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    help development: donate antergos

  • @joksik Glad it helped! Note that the option actually exists and is present in Manjaro. You could do a (dirty) fix by installing the Manjaro package, and you’ll get the option (I mean I tested this and it worked). Manjaro package is v1.2.0 whereas Antergos/Arch is v1.2.1. But in Mint, they have v1.2.1, and it’s working…
    Note also that if you run lightdm-settings without sudo privileges, you get the option! (But of course you can’t save any change that you made).

  • @papa33 interesting. so i search the web why under manjaro lightdm-settings works and i found that they have the same bug but they fix it. its all here:

    https://github.com/manjaro/packages-community/issues/489

  • sorry for refresh but now i have a free time to look more into subject why only under antergos lightdm-settings not working. So i see manjaro team add patch to lightdm-settings that add this missing new option. Patch can be download from here:

    https://github.com/manjaro/packages-community/blob/b8e8bbacfb8171bb76ad3ea36fb71d1a100133bd/lightdm-settings/draw-user-backgrounds.patch

    If i correct we have two options:

    1. add to antergos repo lightdm-settings with this patch
    2. contact with author from aur who maintain this package to include this patch to pkgbuild
  • @joksik Thanks a lot for the feedback. The latest version of the patch seems to be the following:
    https://github.com/manjaro/packages-community/blob/master/lightdm-settings/user_background.patch
    I downloaded it and modified the PKGBUILD of the aur package accordingly, in order to apply it–> makepkg -s
    –>Install the generated package
    –>Success!!

lightdm125 show22 wallpaper21 Posts 14Views 438
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.