• How to enable touchpad while typing?


    Hi all,

    I’m currently running Antergos (XFCE) on a 2013 Macbook Air, and I’m quite happy with it. One problem I have though, is that I cannot use the touchpad while I type, and I’m unsure how to enable it. Can anybody help me out?

    Thanks!

  • To change these settings in XFCE 4’:

    1. Open System Settings.
    2. Click Mouse and Touchpad.
    3. Change the settings on the Touchpad tab.

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Hes right, you can also use synclient -l
    Find relevant setting, then change it to 0 or 1 depending

    If you pretend to be someone else? Who will be you?

  • @joekamprad said in How to enable touchpad while typing?:

    To change these settings in XFCE 4’:

    1. Open System Settings.
    2. Click Mouse and Touchpad.
    3. Change the settings on the Touchpad tab.

    There isn’t an option for that in the touchpad tab.

    @starrider said in How to enable touchpad while typing?:

    Hes right, you can also use synclient -l
    Find relevant setting, then change it to 0 or 1 depending

    bash: synclient: command not found

    Oof. I’ve tried these already. Any other ideas?
    Thanks, though!

  • cat /etc/X11/xorg.conf.d/50-synaptics.conf
    
    # Example xorg.conf.d snippet that assigns the touchpad driver
    # to all touchpads. See xorg.conf.d(5) for more information on
    # InputClass.
    # DO NOT EDIT THIS FILE, your distribution will likely overwrite
    # it when updating. Copy (and rename) this file into
    # /etc/X11/xorg.conf.d first.
    # Additional options may be added in the form of
    #   Option "OptionName" "value"
    #
    Section "InputClass"
            Identifier "touchpad catchall"
            Driver "synaptics"
            MatchIsTouchpad "on"
            Option "TapButton1" "1"
            Option "TapButton2" "2"
            Option "TapButton3" "3"
    # This option is recommend on all Linux systems using evdev, but cannot be
    # enabled by default. See the following link for details:
    # http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
            MatchDevicePath "/dev/input/event*"
    EndSection
    
    Section "InputClass"
            Identifier "touchpad ignore duplicates"
            MatchIsTouchpad "on"
            MatchOS "Linux"
            MatchDevicePath "/dev/input/mouse*"
            Option "Ignore" "on"
    EndSection
    
    # This option enables the bottom right corner to be a right button on
    # non-synaptics clickpads.
    # This option is only interpreted by clickpads.
    Section "InputClass"
            Identifier "Default clickpad buttons"
            MatchDriver "synaptics"
            Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
    EndSection
    
    # This option disables software buttons on Apple touchpads.
    # This option is only interpreted by clickpads.
    Section "InputClass"
            Identifier "Disable clickpad buttons on Apple touchpads"
            MatchProduct "Apple|bcm5974"
            MatchDriver "synaptics"
            Option "SoftButtonAreas" "0 0 0 0 0 0 0 0"
    EndSection
    

    Is what Antergos installs as default, may this is a culprit?

    As i can see it is using syaptic drivers…

    there is also one from xorg:

    cat /usr/share/X11/xorg.conf.d/40-libinput.conf              
    # Match on all types of devices but joysticks
    Section "InputClass"
           Identifier "libinput pointer catchall"
           MatchIsPointer "on"
           MatchDevicePath "/dev/input/event*"
           Driver "libinput"
    EndSection
    
    Section "InputClass"
           Identifier "libinput keyboard catchall"
           MatchIsKeyboard "on"
           MatchDevicePath "/dev/input/event*"
           Driver "libinput"
    EndSection
    
    Section "InputClass"
           Identifier "libinput touchpad catchall"
           MatchIsTouchpad "on"
           MatchDevicePath "/dev/input/event*"
           Driver "libinput"
    EndSection
    
    Section "InputClass"
           Identifier "libinput touchscreen catchall"
           MatchIsTouchscreen "on"
           MatchDevicePath "/dev/input/event*"
           Driver "libinput"
    EndSection
    
    Section "InputClass"
           Identifier "libinput tablet catchall"
           MatchIsTablet "on"
           MatchDevicePath "/dev/input/event*"
           Driver "libinput"
    EndSection
    

    You can try to use this:

    sudo cp /usr/share/X11/xorg.conf.d/40-libinput.conf /etc/X11/xorg.conf.d
    sudo mv /etc/X11/xorg.conf.d/50-synaptics.conf /etc/X11/xorg.conf.d/50-synaptics.conf.bak

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Command: xfce4-mouse-settings

    0_1528833877250_touchpad.png

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • Command synclient is part of package xf86-input-synaptics.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @manuel said in How to enable touchpad while typing?:

    Command synclient is part of package xf86-input-synaptics.

    Makes sense. That package isn’t installed.

  • @ayylmayonnaise
    You may try it, so we see if it helps, maybe not. That package is AFAIK no more developed.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • per default libinput is installed on Antergos… (new install) i do not have synaptic related stuff installed on xfce here…

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad
    I had them both (xf86-input-libinput and xf86-input-synaptics), but uninstalled the latter… All worked, and still works OK.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • SUCCESS!
    Thank you all so much.

  • @ayylmayonnaise
    For the record, was it Joe’s instructions that helped?

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • It was installing xf86-input-synaptics that solved it, sorry for the confusion.

  • No problem, I can understand the excitement when something starts working after trying it hard… 😉

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • There is something going on with touchpads at the moment… a lot of issues… from not working as they should to not detected at all… Let’s see what will come up 😉

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

touchpad45 enable10 typing2 Posts 16Views 280
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.