• X3 Terran War Pack shared libraries issue(s)


    Hi Guys,

    I recently got X3 Terran War from GOG. It seems that the linux installer hasn’t been updated lately and the shared libraries in the game/lib are outdated. I fixed an issue with libz.so.1 by backing up the one that the game came with and then symlinking the one in the system to the game libraries directory. If anybody’s interested then the error I got was:

    ./X3TC_config: lib/libz.so.1: version `ZLIB_1.2.9' not found (required by /usr/lib32/libpng16.so.16)
    

    But now I ran into another error which I am unable to solve:

    ./X3TC_config: symbol lookup error: /usr/lib32/libxcb-shm.so.0: undefined symbol: xcb_send_request_with_fds
    

    It seems that this is another issue of the game relying on an outdated library (i think). The version I have is lib32-libxcb 1.13-1, which is the up to date one on Ubuntu aswell. Has anybody faced an issue like that and do you have any ideas on how to solve it?

    Thanks!

  • @karl
    The reason probably is an incompatible library version.
    Here’s some discussion and potential fixes:
    https://github.com/ValveSoftware/steam-for-linux/issues/4816

  • @manuel Thank you. I got this issue fixed by renaming the library in question in the ./game/lib dir. This led to another library error:

    ./X3TC_config: symbol lookup error: /usr/lib32/libgdk-x11-2.0.so.0: undefined symbol: XRRGetMonitors
    

    I’m not sure I quite understand what “undefined symbol” means. What it says to me is that XRRGetMonitors isn’t defined in the shared object. But running readelf I get:

    readelf -s /usr/lib32/libgdk-x11-2.0.so.0 | grep XRRGetMonitors
       128: 00000000     0 FUNC    GLOBAL DEFAULT  UND XRRGetMonitors
    

    Which seems to indicate that that isn’t the case. Does that mean that XRRGetMonitors links to another library, which isn’t available? I’m not that knowledgeable when it comes to so-s. Is my understanding of the error correct this time? Some tips on where to look/ what to do next would make me a happy camper.

  • @karl
    It might mean just that, but I’m not sure.

    But in general, using an external program which needs some old versions of other libraries may be difficult to get working. If you downgrade or remove installed libraries, it may also make your system a bit unstable.

    So it seems like a puzzle that needs to be solved bit by bit, and the result may not be what you’d want. The only tip I can give for now is to use duckduckgo, google, or something similar.

    Or someone else here may hopefully have more info…

shared9 pack6 war2 terran1 Posts 4Views 224
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.