• Microphone crackling


    two days ago I installed fresh antergos (my very first arch-based distro), but I have issue with crackling sound in records from my microphone. I am sure that problem is not in microphone or my HW (on windows works just fine). My microphone is connected to my motherboard (ASRock AB350) soundcard (HD-Audio Generic, ALC892 Analog as Rear microphone).

    I tried suggestions on ArchWiki (https://wiki.archlinux.org/index.php/Advanced_Linux_Sound_Architecture/Troubleshooting#Crackling_microphone) with no luck.

    I have also tried this (https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/596249).

    Here is output from $ alsa-info.sh:

    I test recording with $ arecord test -f dat and Audiacity.

    Can anybody help me?
    Thank you!

  • @theese do you check with alsamixer already?
    Often you have some sliders or options ther enabled and disturbing…

    like system-beep and mic preamption e.t.c.

  • This post is deleted!
  • @joekamprad I have checked and configured with alsamixer at the first place, it seems OK. But microphone is still crackling. Here is my alsamixer configuration preview: https://imgur.com/a/72P94t5

  • can you make a screenshot from choosing //ALL// [F5] ?

  • @theese said in Microphone crackling:


    two days ago I installed fresh antergos (my very first arch-based distro), but I have issue with crackling sound in records from my microphone.

    First of all, Welcome to Antergos.

    Are you using Gnome for your desktop? The reason I ask is because I am also having crackling in the speakers, and this did’t start until the upgrade to Gnome 3.28 and I don’t even have any microphone hooked up and no internal microphone.

    Try this, temporarily disconnect your microphone(s) and see if the crackling still exists.

    I am starting to wonder if this a bug introduced in Gnome 3.28.


  • i do have this also and i find that on my machine i need to unmute systemspeaker and it goes away… also on anather machine i do have sliders inside alsamixer for two microphones, but only one is connectable… also some lines having the wrong label… like subwoofer is called front… this all started together with Archlinux putting pulseaudio on default… and they all following using pulseaudio… what sits on top of alsa… pulse have some very cool features… but troubleshooting s not funny…

  • Hi, thank you for replies. I am still dealing with the issue.

    @joekamprad Here is screenshot with all settings: https://imgur.com/a/7IDGbjF

    @pudge I use Cinnamon (v. 3.8.4), which derives from GNOME 3. Sound works fine for me, crackling is only in recordings from microphone. I have tried skype call, but the crackling is there too.

    @joekamprad Yes, I have two microphone inputs (Rear and Front), I have tried to mute both separately, and I even tested microphone on both inputs, but with no result. What do you mean by “unmute systemspeaker”?

  • strange that there are two channels for front mic boost… have you tried to disable automute?
    and play with the boost channels? also try to plug into the rear mic plug?

microphone14 crackling3 Posts 9Views 452
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.