• LightDM - Cannot log in


    @fernandomaroto said in LightDM - Cannot log in:

    sudo pacman $(pactree -u gnome) --needed

    pactree : no such command

  • @longliveantergos said in LightDM - Cannot log in:

    @fernandomaroto said in LightDM - Cannot log in:

    sudo pacman $(pactree -u gnome) --needed

    pactree : no such command

    OOPS

    sudo pacman -S $(pactree -u gnome) --needed

    If still doesn’t work reinstall pacman-contrib package

  • @longliveantergos said in LightDM - Cannot log in:

    sudo systemctl disable sddm -f which reactivates lightdm by default (correct?)

    no this is forcing (-f) disabeling only! must be systemctl -f enable lightdm
    what will disable sddm …

    And if accidently uninstalled antergos-gnome or parts reinstall the meta-package can do the job also:

    sudo pacman -S antergos-gnome-meta

  • @joekamprad : Thank you…very much…for your time and effort. i am certainly guilty of not following the dependencies. I thought I must have installed GNOME DE by accident, and in a way I had. i am too new…

    however, what can I do about xfce not using lightdm? Is there an alternative for xfce? I have fresh installed two or three times and keep coming up with the lightdm bounce.

  • @relogi you are using nvidia drivers?

  • To correct my question:
    Are you running on Nvidia Videocard ?

  • try cleaning unnecessary files? I’m not familiar with the command under arch, but in Ubuntu it’s sudo apt-autoclean and sudo apt-clean

    Try that, sometimes it wont log in because of insufficient space

  • sudo pacman -Scc

  • df will show all used and free space on hd’s

  • sudo paccache -d

    and then if there to prune …

    sudo paccache -rk0

  • @longliveantergos said in LightDM - Cannot log in:

    sudo pacman -Scc

    -Scc it is very dangerous, in any case start with -Sc

  • @fernandomaroto said in LightDM - Cannot log in:

    … enable sddm -f and reboot

    Hello @fernandomaroto !

    According to Arch --f or-f force is not used anymore with the new pacman, now and less forceful, according to say the command --overwrite is used.
    http://allanmcrae.com/

  • @judd said in LightDM - Cannot log in:

    @fernandomaroto said in LightDM - Cannot log in:

    … enable sddm -f and reboot

    Hello @fernandomaroto !

    According to Arch --f or-f force is not used anymore with the new pacman, now and less forceful, according to say the command --overwrite is used.
    http://allanmcrae.com/

    but @fernandomaroto was providing a systemd option ;)

    sudo systemctl enable sddm -f
    
  • @joekamprad said in LightDM - Cannot log in:

    pero @fernandomaroto estaba proporcionando una opción systemd
    sudo systemctl enable sddm -f

    👌 👍

  • @judd 🕵 🖖 Pero entonces pude leer algo escrito por ALLAN, que siempre es refrescante

  • @judd
    Ah thanks for the info, i also know that --root option is no more and i used it a lot to test stuff for new isos.

    Anyway, as @joekamprad said i was recommending the use of force option for systemd not pacman (as far as i know it still works).

    I also have to say that i’m totally lost in this posts, is the problem solved after all? There are so may paralel issues here :)

    “Living in the Land of the Lost”

  • Dear @fernandomaroto fernando The pb is solved, thanx to all of you. I didn’t know that sudo pacman -Scc is dangerous. I never had any kind of pb using it.

  • @fernandomaroto ha ha I feel lost under all the current issues also!
    Some very similar and others with everyone inside.
    But most issues get solved, and we get a very nice communication all over the Forum.

  • @joekamprad - That is absolutely true ! And I will take advantage of your statement to thank everyone - especially you, @fernandomaroto and @anarch (just because you are the ones I have “talked” to) for being ALWAYS helpful and trying to solve our pbs. I guesss you spend a lot more time here than I could or would if I had the knowledge you have. So, really, thank you again very much for what you do for us “newbies” and for everyone else on this forum who is looking for help. It is gold!

  • @fernandomaroto said in LightDM - Cannot log in:

    @longliveantergos
    Hi!
    Try installing sddm with:
    sudo pacman -S sddm-kcm sddm; sudo systemctl enable sddm -f and reboot

    Hi fernandomaroto - I was facing similar Problem
    In my case “Failed to start Pamac” - After the chroot from a Live CD and putting in your above command…during the upgradeing it showed several times:
    "Warning: Directory permission differ on /usr/lib filesystem 700 package 755
    (It has to be said that shortly before the Crash I changed the permission for this Folder into 755 - it could be the reason for the Crash…or just coincidence)…
    .
    Now after the above Installation on your above proposal -
    I can’t still not boot correctly …but now it Comes a different Problem:

    “Failed to start Network Synchronization” - several times
    also “Failed to start Manager, Install and Generate Color Profiles”

    Yes I do have ndivia - but with the above Installation I also did
    “pacman -S nvidia-installer” as preaucution.

    Thank you for any help in this matter.
    And Good Night to everybody - I will check tomorrow

    Thanks

lightdm137 Posts 41Views 2075
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.