• LightDM - Cannot log in


    Dear all, I have again the log in pb with LightDM, on a desktop this time. It happens after an update. After entering my pw I get 3 choices for the desktop (default, fallback, cancel), none of them works. Tried to install gdm with sudo pacman -S gdm, I get an invalid package so this does not work either. I reinstalled gnome AND gnome-extra to be on the safe side - does not help. What can I do to get LightDM working again, please? All good ideas are most welcome and thx in advance for your help.

  • @longliveantergos
    Hi!
    Try installing sddm with:
    sudo pacman -S sddm-kcm sddm; sudo systemctl enable sddm -f and reboot

  • Thx very much Fernando. You know why I hesitate? I installed sddm a week ago because I had the same log in pb on a laptop. I was never able to log in under ssdm and had no menu with icons… (https://forum.antergos.com/topic/7736/login-impossible/21?page=2).

  • @longliveantergos
    Hi!
    I understand, sddm only broken once here in a year or more, while other login managers used to cause me more trouble. (but i don’t know if you may find issues using gnome desktop for example)

  • ok, I try and let you know. I wouldn’t know how to fix lightdm anyway…

  • @fernandomaroto LightDM has worked perfectly for many years on several computers I use, so I am a bit surprised by this sudden “breakdown”.

  • @fernandomaroto said in LightDM - Cannot log in:

    sudo pacman -S sddm-kcm sddm;

    When I do that an error msg says “Cannot find target ssdm-kcm” (my internet connection works).

  • Having the same log in issues {entering username and password and getting bounced back} and: i replaced lightdm with gdm (using [ctl+alt+F2 to get to tty login, sudo pacman -S yada yada) which gets me the same place… bounced back. As a curious side not, I changed from xfce to GNOME DE on the gdm session menu and logged in just fine…only i never put GNOME onto my machine. I chose xfce… what is going on?

  • @longliveantergos said in LightDM - Cannot log in:

    @fernandomaroto said in LightDM - Cannot log in:

    sudo pacman -S sddm-kcm sddm;

    When I do that an error msg says “Cannot find target ssdm-kcm” (my internet connection works).

    You misstyped, the correct is sddm-kcm

  • Oh sorry! That is stupid. Will try again tonight when back from office. Thx !!

  • @relogi because you install GDM and do not check what it installs as dependencies?
    GDM is made for GNOME and it will install gnome-session and gnome-shell, so a minimal GNOME desktop.
    dependencies of GDM:
    0_1528705951330_Bildschirmfoto vom 2018-06-11 10-31-43.png

  • But I do use gnome…

  • @longliveantergos my post was for @relogi and he was using xfce…

  • @longliveantergos
    at the moment lightdm login to GNOME itself has no known bigger issue… so your problem is may caused by a extension?

    If you can not get into GNOME you can take a look into:

    ~/.local/share/gnome-shell/extensions

    of youor users dir, there are the folders for extensions, you can disable by moving this folders out of the way:

    mv ~/.local/share/gnome-shell/extensions ~/

  • Thx again, msg says /home/bob/.local… No such file.
    I installed sddm but cannot log in. Pressing Enter after typing my pw has no effect. I am lost.

  • @longliveantergos said in LightDM - Cannot log in:

    Thx again, msg says /home/bob/.local… No such file.
    I installed sddm but cannot log in. Pressing Enter after typing my pw has no effect. I am lost.

    then you may have no gnome-shell-extension installed ?

  • Would be surprising. How can I check, please?

  • they will be inside this directory if you install them …

    ls ~/.local/share/gnome-shell/extensions
    

    shows something?

    you can also try getting errors from journal about extensions:

    journalctl /usr/bin/gnome-shell -f
    
  • Thank you @joekamprad - I deactivated sddm with sudo systemctl disable sddm -f which reactivates lightdm by default (correct?), then typed sudo pacman -S gnome and selected gnome-shell from the list. Now I can log in again (under lightdm) and errors from ls ~/.local/share/gnome-shell/extensions are creating an endless list. Very funny. I don’t want to take too much space here, how can I attach the log in a “discreet” way, please?
    I am manually uninstalling packages (mostly games) that I don’t need, but probably I could have selected a different gnome-something for the same result. Which gnome is installed by default with antergos?

  • You can try reinstalling missing dependencies, if there is any missing with:

    sudo pacman -S gnome just in case (not using meta-package from Antergos).

    Also:
    sudo pacman $(pactree -u gnome) --needed

lightdm130 Posts 41Views 1815
Locked
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.