• XPS 13 - Laggy Performance Under Gnome


    Hello Everyone,

    I recently posted about my Dell XPS 13 (9350) having laggy performance under Antergos with Gnome DE (using Wayland). One of the suggestions I got was to tweak the following:

    "Id recommend changing the EPP of the processor to "performance" and see if that helps. I found this online:
    
    "In my case (Skylake i7-6500U laptop) it depends on the value of the energy_performance_preference (EPP) variable.
    
    If it is balance_performance it works OK, if it is performance it works great, if it is balance_power or power it is super sluggish.
    
    You can inspect the value of this variable for each core with this command: cat /sys/devices/system/cpu/cpufreq/policy*/energy_performance_preference
    
    You can set it to performance with this command: echo performance | sudo tee /sys/devices/system/cpu/cpufreq/policy*/energy_performance_preference"
    

    Question:
    Will I do any harm to my system if I make the change above? Currently my system is set to “balance_power”, and I use TLP as well.

    Any thoughts or feedback would be greatly appreciated!

  • @a4orce84 said in XPS 13 - Laggy Performance Under Gnome:

    energy_performance_preference

    do you have this files?

    ls /sys/devices/system/cpu/cpufreq/policy0 
    affected_cpus     cpuinfo_transition_latency     scaling_cur_freq  scaling_setspeed
    bios_limit        freqdomain_cpus                scaling_driver    stats
    cpuinfo_cur_freq  related_cpus                   scaling_governor
    cpuinfo_max_freq  scaling_available_frequencies  scaling_max_freq
    cpuinfo_min_freq  scaling_available_governors    scaling_min_freq
    

    I know from some buggy machines that setting the governor is helping a lot, but it was mostly set it to popwersave because they run full power all the time with out setting a governor…

    https://www.kernel.org/doc/html/v4.12/admin-guide/pm/intel_pstate.html

    As your system is set to balance_power or power and is super sluggish, same as what the helper say… i would give it a try… If something happen you can revert this settings, also from livesystem…

  • Hey @joekamprad

    I do have those files as well. Is there something specific you wanted me to edit or modify with them?

    Thanks man.

  • @a4orce84

    echo performance | sudo tee /sys/devices/system/cpu/cpufreq/policy*/energy_performance_preference"
    
  • @joekamprad said in XPS 13 - Laggy Performance Under Gnome:

    echo performance | sudo tee /sys/devices/system/cpu/cpufreq/policy*/energy_performance_preference"

    Output:

    [[email protected] ~]$ echo performance | sudo tee /sys/devices/system/cpu/cpufreq/policy*/energy_performance_preference
    performance
    [[email protected] ~]$
    

    Done!
    Is this setting things to the ‘performance’ setting? Not sure what’s happening here.

  • Sorry, I just realized you are doing what my original post said to do to “set” the performance setting. I have done it and just rebooted. Will monitor things and keep an eye on stuff.

    If I need to revert, I am guessing I just need to do the following:

    echo balance_power | sudo tee /sys/devices/system/cpu/cpufreq/policy*/energy_performance_preference
    

    Is this correct? Thanks Joe!

  • yes that will revert the setting, but iam not sure if the setting resist a reboot so take a look what it say after rebooting …

  • Looks like it reverted back to ‘balance_power’ after the restart. I re-set it to Performance and will monitor on the live system.

  • i can take a look into this tomorrow, but its gone late today here ;)

  • You probably need to do this on every reboot. I hear there are a ton of power saving features added in the next kernel, but while waiting for that you can always make a script and executing it on startup. I guess a systemd service would be easiest:

    https://linuxconfig.org/how-to-automatically-execute-shell-script-at-startup-boot-on-systemd-linux

  • Thanks guys! So, I fixed the sluggish issue FINALLY. I go into more details below:

    Behavior:
    So, I usually use my laptop unplugged (not connected to the power charger). Mainly when I’m on the go, or sitting on the sofa. I mean that’s the main reason I bought this ultrabook (Dell XPS 13) so I can use it without being tied down to a desk or AC outlet. However, I was doing some work at a coffee shop and plugged in to charge my battery. I IMMEDIATELY noticed that the sluggish behavior was gone. Not only that, Antergos almost felt like Windows 10 in terms of smoothness (Application switching and even typing things), as well as my touchpad felt 50x better…smooth and no jittery / jumpy behavior.

    I ended up doing some research and tracked my issue down to ironic enough TLP. Specifically, the following post described my bug I believe:
    https://www.reddit.com/r/linux/comments/6cj4ow/wonder_why_your_gnome_shell_feels_jerky_or/dhvkofc/

    The Solution:
    As the post said, I made the following change to my TLP config:
    HWP_ON_BAT=balance_performance

    And everything feels great! It even persists through reboot’s without any issues. I’ll monitor things for a few days, but I am pleased with the results so far. I know it’s going to eat a bit more battery life being in ‘performance’ mode, but I’ll sacrifice some battery for an overall better experience under Antergos.

    Thank you both for all of your time and help. It is greatly appreciated!

  • ha good one! so you find the way to make this permanent, and it looks like TLP can handle this, and also was the reason why the setting was set like you have them before?

    Powersaving setup under Linux can go abit tricky, as they are so many providers …

  • Hey @joekamprad,

    I just used the “vanilla” TLP that comes with the package. I did not modify anything, so out of the box it sets those “HWP_ON_BAT=” values. I may need to go back and adjust a few others, but so far things are still working fine.

    Not sure if there is a best practices link or blog on how to ‘tune’ TLP correctly or not.

    P.S. - You proud of me yet? =)

    Thanks,
    Asif

  • 🏆

    Good job Mr. !

    I have created a startup of a hwto do energy savings here:

    https://antergos.com/wiki/hardware/power-saving-made-easy/

    everyone is involved to add something or like Mr. @a4orce84 help on enhacing it!

  • Well, I don’t know much. Just need to read up more on TLP at this point…who knew it would bring my laptop to it’s knees with it’s default configurations.

gnome322 xps25 performance9 laggy4 Posts 15Views 979
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.