• Asus Sabertooth Z87 with Samsung 970 pro with PCIE adapter


    Hello!

    this is regarding: Asus Sabertooth Z87 with Samsung 970 pro with PCIE adapter

    I have installed the hardware, i can install windows 10 / OpenSUSE, Antergos onto the new NVME SSD but i cannot boot from it. please help me.

    there are no boot options at all, i used the default settings during the installation.

    i have the latest official bios.

  • @premier69
    Do you mean none of the mentioned operating systems are booting?
    If so, then it may be that your motherboard does not support booting from NVMe disks.

    In that case the only option would be to use another disk for booting (only), preferably a small SSD with Sata3 interface. A USB stick could also be used as a boot device, but that may be a bit slow… but if that is not a problem for you, why not try that.

    But I’m not an expert on NMVe since I have no such disks, someone else may know more.

  • I think you are right about my motherboard not supporting nvme, i bought it 5 years ago, it’s haswell so this is before M.2.

    However, is it possible to get some workaround done?

    booting up i get this message right after bios post check:

    "the current BIOS setting do not fully support the boot device. Click OK to enter the BIOS Setup.

    Go to Advanced > Boot CSM Parameters, and adjust the CSM settings to enable the boot device".

    I have, I don’t quite understand the settings available there so I’ve tried some random combinations. EFI, Legacy, and in what order…
    Would you like a screenshot or do you know what I’m on about?

  • @premier69
    This is a good tutorial about installing Antergos: https://antergos.com/wiki/install/installing-antergos-2/

    And this gives more details: https://wiki.archlinux.org/index.php/GRUB

    I’m pretty sure you can make the machine boot (by using another drive as the boot drive) and store everything else to the M.2 SSD (so that the machine runs fast).

    In BIOS, you can select either UEFI (EFI) boot mode, or Legacy boot mode (not sure if they are named there exactly like that). UEFI is a newer specification, thus it is recommended over Legacy boot (but you can test which one works better).

    Do you plan to install only Antergos, or also other operating systems?

  • @premier69

    And OK, please give a screenshot or more info about your related BIOS settings.
    You can use the following command to show it here:

    cat <your-bios-screenshot-file> | curl -F [email protected] https://ptpb.pw/?u=1
    

    unless the normal picture uploading doesn’t work for you just yet (there’s a potential spam filter…).

  • You could just try this (assuming you will have only Antergos on your M.2 drive):

    • have another (empty) USB stick to be the boot device and plug it in
    • start Antergos installer, and start a terminal before proceeding with install
    • give terminal command: lsblk -fm and find your USB drives, you’ll need their drive names (like /dev/sdb) later (you’ll see also that M.2 drive)
    • install Antergos in Legacy mode to the M.2 drive
    • during install, select the extra USB drive as the MBR target disk
    • follow the rest of the instructions as you see fit

    This already might make your system bootable (to Antergos).
    Note however that his is more like a test for workaround idea, but if this works for you, there is no reason why not start using it permanently.

asus17 samsung9 z871 sabertooth1 Posts 6Views 666
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.