• It seams impossible to install Antergos, new errors every time!


    • Grub could not find the hibernation (swap) partition.

    • mount:/new_root: can’t find UUID xxx You are now being dropped into emergency shell

    Both are errors that can be solved by regenerating boot images and grub.cfg, and check /etc/fstab if it is right with UUIDS from lsblk -fm

  • I already coverd the fact that the UUID’s are right, but have not gotten as far as regenerating the boot images or grub.cfg. Also: doing so will differ slightly with a separate /boot partition vs a /boot folder in /root.

    On this system (the one I am writing this on), I have a separate /boot partition, but also a /boot folder in /root. Therefore it depends on what is stored and operates from where. Is the /boot folder a backup? Why do I have both instead of just one or the other?.. More questions needing sorting out for better understanding, before making things worse.

    I still have a few hours of work to do, so I can return a clients guitar and get paid for my work (I build and repair them), make dinner, and then I will get right on it. I will gladly share my findings when I know more, hopefully it will be of help to whomever is facing the same dilemma.

  • @zoidmo said in It seams impossible to install Antergos, new errors every time!:

    Also: doing so will differ slightly with a separate /boot partition vs a /boot folder in /root

    No.

    All files on a linux system are under / also /boot, if you have a seperate boot partition it will be mounted on the same place this what you should see in the /etc/fstab as well.

    If you chroot into a installed system you go go mount the partitions by hand, as system is not loaded by itself.

    so if you have a seperate partition for boot, you mount it under /boot after mounting your root ( / )
    (sample where sda1 = boot partition and sda2 = / partition

    mount /dev/sda2 /mnt
    mount /dev/sda1 /mnt/boot
    

    If /home is on its own partition (sda3) then it will be mounted into / (root) filesystem too

    mount /dev/sda3 /mnt/home
    

    Then you can chroot inthe the mounted installed system under /mnt (where you mount all needed filesystems)

    arch-chroot /mnt
    

    once chrooted into the system you can use mainly all commands as root:

    mkinitcpio -p linux >> regenerate boot images ( /boot/vmlinuz-linux /boot/initramfs-linux.img )
    grub-mkconfig -o /boot/grub/grub.cfg >> regenerate grub.cfg

    inside fstab with UUIDS entries look like this:

    UUID=9085bc2f-df73-415f-8828-d52b5206e0cb /boot ext4 defaults,noatime 0 0
    
  • @zoidmo
    Here are some useful terminal commands. You can start a terminal after booting with the USB installer stick.

    Regenerating grub.cfg:

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    A separate boot partition needs to be mounted to the /boot folder of the root partition. That’s why there is a /boot folder.
    So the /boot folder is not a backup. But if there are files already, then the boot partition is not for that installation.

    Mounting the boot partition is done automatically with a line in file /etc/fstab:

    UUID=<uuid-of-the-boot-partition> /boot ext4 defaults
    

    assuming the boot partition is in ext4 format.

    The line can be added with these commands (after booting with the USB stick installer):

    sudo mount UUID=<uuid-of-the-root-partition> /mnt
    sudo nano /mnt/etc/fstab
    

    and then add the line in the nano editor.

    @joekamprad Just noticed your post, but now that I’ve written it, I’ll just release it. ;)

  • @manuel our posts play very well together ;)

  • My PC with the boot partition is fine for now, but I remember a recent update to grub, and now one for the kernel, so I think I will hold off with that for now, until I know more, because according to what I have read, installing them may be asking for trouble!

    The PC that is affected doesn’t have a separate boot partition this time, don’t forget I am on my 3rd attempt with different config’s of which all failed.

    So, I will check if the UUID’s are right everywhere, for the third time, but they have been so far, so the UUID’s are not the problem, and most certainly not those just trying to install an OS with options they are given to choose from, and blame shifting is uncalled for; I did nothing wrong, or out of the usual that should not work. The problem seems to be that either grub or boot configurations are not being done right or at all, during install (in my case) and after grub or kernel updates for others (why I won’t update them until I know it’s safe), and therein lies the failure.

    So, those who make grub, or any software responsible need to fix it, as even if the users can fix it, it’s a workaround only, and the real problem still exists, and more and more computers will be affected, until the real problem is fixed (plain simple logic).

    Now I will try to regenerate the boot and grub configurations and see what happens.

  • OK, I checked to see if the UUID’s were right in fstab, and grub.cfg, and they were right again. I mounted root, chrooted into it, regenerated the boot images, and it ran, but did give a “missing firmware” warning for wd719x and aic94xx. I looked up the warning, but everyone says to just ignore it, as it won’t hurt a thing, and it can be installed later from AUR just to get rid of the warning in the future.

    Next I regenerated grub.cfg, and got an error there too, this one said “failed to connect to lvmetad, cannot find grubdrive for /dev/sde1” , but since sde1 is the Live media, and not a second OS to be chosen at boot, I ignored it, besides the regeneration finished without further complaints.

    I exited chroot, and rebooted the PC, but it didn’t work, I got the same error as before, again with all of the right UUID’s!!! THIS IS INSANITY!!!

    I will now look into what I read about entries in grub.cfg having parts out of order, try to install the missing firmware just in case, if I can under chroot, and see how that turns out.

    Also: @joekamprad I downloaded your Antergos rescue.iso, (very hard to find, as you moved it, and none of the links I found to it worked, not even a redirect). Info is also hard to find, and it’s not well documented as far as I can tell. Is there anything on there to deal with grub problems? If not, you may wan’t to add it.

    So I may try it or the “Linux Rescue CD” which I have used a few times for data recovery and to fix other distro’s in the past. It has a grub repair app with a GUI, and since it is older, will not have the same problem this nightmare is caused by.

  • @joekamprad Tried your Iso, and after the boot selection screen and the usual “write through” message every Linux distro throws out, it just hangs and nothing happens.

  • Well, I just spent another 3 hours trying to fix it, and still get the error. According to what I read it could be any number of things with the boot loader (grub), initrd with missing or no modules, bash not being present when a script was called and all kinds of other stuff but not hardware or user error (the PC is well within requirements, has no unsupported hardware, and everything works accept the MMC card reader). It basically comes down to this:

    Something did not get downloaded installed or configured right during installation, or it did but was corrupted. So as seems all to common with Antergos, it most likely has to do with poor mirror maintenance, (I have never had internet connection issues, and my connection is rock solid and fast) I have never had these issues with any other distro.

    It could take weeks for me to figure this out, and I can’t provide any logs or info right now, because I do not have any way of saving it to any media and transferring it to this PC to send it to you. Hell I have been swapping the wireless card back and forth between PC’s to do all of this, and not being able to store info between sessions of the Live media which has plenty of space doesn’t help (I still don’t know why the free space can’t be a usable partition, sounds silly to me).

    Personally, I think Antergos developers need to figure this out, and find out where the problem is, and reevaluate how and who manages and maintains the mirrors, because it’s obviously not working, and it can only hurt you by giving you a bad rap and diminishing donations.

    Here’s a suggestion: A two stage install: 1. An offline and fail safe installer (tried and true, nothing fancy and not “the latest and greatest”). 2. Software installation and upgrade, because once up and running, one has more capabilities to deal with problems, and what not.

    If there were more utilities to deal with problems and helpful documentation to go along with it right on the desktop on the Live media (@joekamprad has the right idea) it would be a welcome and much needed addition. It would cut down on traffic here on the forum too, and free up more time to improve the distro.

    That way Antergos will be more “For Everyone” than it is now, because not everyone has internet access (but can use it when they get a chance), and most of us can not deal with “when stuff doesn’t work” scenarios.

  • @Zoidmo sorry but all that many words are offtopic.

    –closing–

    feel free to open a thread under offtopic or go to #antergos-offtopic on IRC.

  • My Antergos_:Rescue ISO is under BETA HEAVY DEVELOPMENT and not ready for real use jet, but thanks to link me that i need to change the link to the project at sourceforge, i also add it to my signature now.

    If you still want/need help on your issue open a new thread on this and give all needed information.

    Grub itself is working very good and without bigger issues on itself, as we can see on the very limited numbers of problems like this.

    Your problem with device namng looks stange, and could be related to hardware setup, or EFI/BIOS settings.
    (we do not get any information about your system to get into the issue)

impossible14 time3 seams1 Posts 31Views 1411
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.