• It seams impossible to install Antergos, new errors every time!


    I have been trying to install Antergos on a second PC for a week now. (antergos-18.6-x86_64.iso)

    Besides the mirror problems, which I have tried everything and nothing worked until it finally just installed as it did on the PC I am on now months ago, and again without doing anything but waiting some time and trying over and over again, and without any hacking around, it just worked all of a sudden.

    All happy about finally succeeding, I was met with a big let down on reboot: Grub could not find the hibernation (swap) partition. I looked up the error and found this thread:

    link text

    I didn’t get far because at the step to change GRUB_LINUX_… I hit a wall at “cd /etc/default/grub”, but because grub is a file, and not a folder, I got the “No such directory” error. So I tried sudo gedit grub, but got “no such command gedit”, (XFCE) and I can’t edit the file without an editor, now can I? (the thread could use some detail). I did although notice something strange: the partitions I created manually were in the order I created them, not in the order they are on the drive: I created a boot partition first, then a 7Gb swap at the end of the drive to get around doing the math, and it ended up sde2 instead of 4.

    I reinstalled knowing the mirrors worked, and just let it partition the drives for me with the separate /home option, and again it installed. But then on reboot I got the same error, and got 3 additional errors.

    1. ERROR: device UUID xxx… not found. Skipping fsck

    2. mount:/new_root: can’t find UUID xxx You are now being dropped into emergency shell (new_root? that does not look right)

    3. sh: cant access ttyi job control turned off

    I ran blkid, and that actually worked. all of the UUID’s were exactly as they should be accept one oddity: They were all on /dev/sde ( I only had one drive installed, to avoid problems, knowing I could make changes after successful install). I have installed all kinds of Linux distro’s over the years, and /boot and /root were always on /dev/sda!

    needless to say even chroot didn’t work this time. (I was hoping to be able to use VM to edit grub)

    Sorry, but I have no way to save and furbish you with any usable info from the system as it is.

    Any help will be greatly appreciated, as I am on my wit’s end, but please give as detailed info as possible, so I don’t run into another wall, as I am not very familiar with low level operations.

    The flazzum you spizz, the zoider you splat!

  • @zoidmo
    Some ideas:

    • edit that file with the following command:
    sudo nano /etc/default/grub
    
    • show info about partitions and drives:
    lsblk -fm
    

    Then about installing: you may choose manual partitioning instead of automatic partitioning. Then you may put all files under one partition, the root partition. No need to have many partitions for a simple thing.

    Here’s some more info about installing Antergos: https://antergos.com/wiki/install/installing-antergos-2/

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • Thank’s Manuel, I will try the nano editor (I thought that nano was DE dependent, like gedit under gnome or XFCE or kate under KDE).

    For reference: What does the added -fm do or stand for in blkid? I suspected that I may have been looking at the drives as mounted at the time, but I dont remember seeing the USB drive listed at all ( I will try again just to ease my own mind).

    As for installing to a single partition, without /boot /home or /swap has many disadvantages, and could spell disaster if something else goes wrong. I already have been devastated by not having a separate /home before, and the system has limited RAM, so having a swap drive especially on the SSD (only one) is of great help. I was trying to be smart, not fancy :>) Besides, manual partitioning didn’t work either, and gave me 3 fewer errors, as stated above.

    The flazzum you spizz, the zoider you splat!

  • @zoidmo
    The command is: lsblk -fm
    The -fm part just shows some additional info about filesystems and partitions.

    Installing to more than one partition has its benefits on many situations. But my systems are typically very simple (and I try to keep it that way 🙂 ), so usually I use only one partition.
    Of course swap may well be necessary (depending on the amount of RAM and usage of applications), but instead of a swap partition, I prefer a swap file (although I hear it is not supported by btrfs).

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • I am trying what you suggested above, but it’s not working.

    first let me say that as far as blkid and lsblk, the UUID’sare identical, so both work for this purpose.

    In the thread I linked to, the one that is missing info, that you don’t seem fit to correct (2 years old or not), it says to edit GRUB_CMDLINE_… 'quiet to 'quiet /dev/sda2. The line ends with 'quiet resume:<UUID of the drive> (THE RIGHT ONE!) IOW not /dev/sdX which may be newer, and it makes a lot of sense because if a drive gets removed or moved, then the UUID will still be right, where /dev/sdX could end up sdY and be wrong.

    non the less, I added the /dev/sda2 in between “quiet and resume”, saved it (If that is wrong, I can change it back), and proceeded with:

    sudo mkconfig -o /boot/grub/grub2
    

    But that returns an error: sudo: mkconfig command not found

    was I to exit terminal first? And if so, the other thread fails to mention that too (I can not find an updated equivalent to that thread!)

    The flazzum you spizz, the zoider you splat!

  • @zoidmo

    The command line should be:

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • Sorry where I wrote “was I supposed to exit terminal”, I meant “exit chroot”, but I can’t edit my replies (tried several times) as it generates a “Lost connection error” which is not only strange, but false.

    I am rebooting and starting over with this procedure, I don’t wan’t to reinstall quite yet, as I already have a few times and got the same error, so I can’t see how having only one partition can possibly help, as Grub does have the UUID’s right, it also makes me question the whole procedure for the same reason, because I just can’t see how adding the device ID is better, when Grub seems to use the UUID now, and the one it is using is correct!

    The flazzum you spizz, the zoider you splat!

  • @zoidmo
    That “lost connection error” is a known bug in the forum software, and it prevents e.g. from editing previous posts.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • I know, It’s persisted for quite a while now.

    The flazzum you spizz, the zoider you splat!

  • How about this (may be a tough one to answer though):

    I am running the drive off of an SATA port, but also have an IDE to SATA addaptor installed because I intend on installing more SATA drives than I have ports for (haven’t used IDE in ages), but as stated, I only have the one SSD on an SATA port for now, to avoid installation problems, and I can’t see it being culprit, as no additional UUID’s are present.

    Also: The Antergos ISO picks random device ID’s on install, as whenever I use GParted from within the live media I get dev Id’s of sde and now sdf , in fact skipping sdb, sdc and sdd. Now if the USB media is sda, I would expect them to continue with sdb. Does it keep info between installation attempts? And if so, why doesn’t it remember all of the other info I have to reenter every time?

    I am also searching high and low for answers elsewhere, but it doesn’t help when people are asking questions wrong in the first place (like “can’t start computer” with no telling details!).

    The flazzum you spizz, the zoider you splat!

  • @zoidmo
    If you could show the output of commands

    lsblk -fm
    sudo fdisk -l
    

    so we have more info about the problems?

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @zoidmo
    And while at it, could you also show the output of

    lspci
    

    ?

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • Well, there’s nothing in there I don’t understand myself, just like with the page “how to install Antergos” which I have read years ago, and Is for beginners, and doesn’t at all cover what to do if something doesn’t work. I am way beyond all of that.

    I have found additional information, and it seems to be that many have been having this problem, many on Manjaro (Arch) with recent kernel updates (4.4) and fresh installs, but also on Dabien based systems like Ubuntu… It has to do with Grub and possibly fsck, and their configuration files being written out of order, not any installers or user errors.

    I had to give up last night, and sleep for a change, and have to attend my shop. I will work on it later today and follow some of their suggestions. I will report back here with more info (hopefully the fix), as soon as I know more.

    I did reinstall one more time, this time without a separate boot drive, but no difference. It does not appear hardware related according to what I have read, and the bug trackers are working on it too now.

    The flazzum you spizz, the zoider you splat!

  • @zoidmo
    Have you considered installing Antergos as a VM into VirtualBox?

    In fact I am often working with virtual machines, and it is quite relaxing since there are no pesky hardware issues (other than a VM is a bit slower, and some games can’t be played). I do many things on virtual machines here.

    Of course I have native installs of Antergos on three machines, and they all work very well. I’m just lucky (I guess) to have Intel graphics on all of those machines, that makes one big headache non-existent (compared to some nvidia or amd graphics systems). Since I’m not playing any heavy games, Intel graphics suits me perfectly.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @zoidmo without any details it is hard to understand what is going wrong for you.

    May your problem is related to advanced partiotion stuff and you missed to but the mountpoints as the should, or it is related to some Bios/EFI settings that do not set right.

    So any deeper Information abou your system, and about exactly what you create on partition screen for the install will help here,indeed also the outputs from the commands @manuel asks for.

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • The reports affect EUFI and MBR, DOS and GPT, Ext4, ZFS, Encrypted and non encrypted… As I said very likely not hardware related. It happens on any file system, which is just more evidence that it is in fact Grub or some other low level software’s not playing well with each other, as others suspect too.

    I wouldn’t call what I am doing in partitioning “Advanced”, and Linux is the most flexible and capable with it and file systems, and has been for a long time. I am very familiar with it (especially with hardware), including moving partitions around, mounting techniques, fstab and configurations… including making everything work with new arrangements.

    I am not a beginner, and have been doing that stuff since DOS, Windows 3, and early Linux distro’s and Unix, and then some (since 1979). I am just not savvy with all of the modules and command line stuff, because I don’t go there unless something breaks.

    I have never played with VM yet, and have so far done fine without, not that it’s not a good Idea, but I just haven’t had a need. I don’t repair computers (only my own), develop or test software, websites or anything like that. I rarely make mistakes, because I do my homework first before trying new things, and normally wait for others to mess up first, and wait until all the bugs and details are worked out on new tech, before I try for myself.

    In this case I did what has always worked (for the most part), and I am sure it has nothing to do with what I did, as none of it is new to me, including the PC and hardware I am working on, which has worked for years under Linux. IOW, the hardware is nothing new, the problem with grub is new.

    Please be patient, and stand by, as I have to catch up with my business and clients first, before I get back to this.

    The flazzum you spizz, the zoider you splat!

  • @zoidmo
    I’d like to help, but without the required information I cannot do that.
    Please provide the info I asked for, otherwise I’m unable to continue.

    If you need any assistance with providing that information, there are many of us here that can do it. But we need your co-operation here.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • One more link that did not post when I pasted it: https://forum.antergos.com/topic/8117/unable-to-boot-uuid-device-not-found

    The flazzum you spizz, the zoider you splat!

  • Sorry, but I just don’t have time right now!

    The flazzum you spizz, the zoider you splat!

impossible12 time3 seams1 Posts 31Views 603
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.