• System won't boot after fresh install of Antergos


    Did a fresh install on old laptop with fresh 18.6 iso. I chose manual parition scheme with following as I didn’t want a swap partition -

    new partition table type mbr (msdos)
    created a new partition type ext4, primary, mounted at / which uses full disk

    I am posting image from manjaro wiki as they had screenshots, mine looked exactly like whats described in section “A Two-Partition Scenario” but I didn’t create swap -
    https://wiki.manjaro.org/index.php?title=Graphical_Installation_Guide_for_Experienced_Users_0.8.8#Choose_Your_Partition_Table_Type

    alt text
    alt text

    Install went fine. But when I boot I see grub screen, then ‘loading 238’ message, then screen just stays blank.
    I had chosen to install LTS kernel, choosing that option has same result.

    What do I do now? DId I do something wrong and how do I troubleshoot?

  • what is your laptop model? may some info about the hardware insiode, GPU, BIOS or UEFI system ?

  • The laptop is Think pad T61p. Can see details here - http://www.thinkwiki.org/wiki/Category:T61p
    It has Nvidia Quadro FX570m gpu, during Antergos install I chose ‘Nvidia drivers’ because of this reason.

    It does not support UEFI as far as I know so as I said, disk uses MBR and I made a single partition during install.

  • @defc
    Seems that it has Intel graphics, too.
    So there are some options:

  • @defc said in System won't boot after fresh install of Antergos:

    FX570m

    this is not working with latest nvidia drivers, and as it needs nvidia-340xx (latest supported driver) if you want to use propritary driver you will need to keep xorg downgraded to 1.19, as latest xorg is not supported by the driver.
    see here: https://antergos.com/wiki/hardware/graphics/antergos-nvidia-installer-2/
    So better to make use of nouveau (open source ) driver.

    What you can doo is arch-chroot into system from Live Installer (1) , or boot into non-graphic: (2)
    https://antergos.com/wiki/miscellaneous/howto-boot-without-graphical-environment/

    For (2) you will need to connect to internet from CLI, on (1) you can do this more comfortable, but needs to arch-chroot :

    mount System to /mnt

    You need to know which device is the right one check with sudo fdisk -l

    sudo su

    /dev/sdXn should be replaced with the right device information from fdisk command output.

    mount /dev/sdXn /mnt >> / root partition

    arch-chroot /mnt

    pacman -S nvidia-installer
    nvidia-installer -n

  • Thanks eveyone. I have never done chroot etc before. Would it be simpler for me to do a reinstall and not choose ‘Nvidia drivers’ in installer? I have no data on system to lose.

    @manuel I think the Intel gpu is an option, my laptop has Nvidia gpu. I dont think it has both.

  • Yes! i would also prefere a new reinstall and not choose ‘Nvidia drivers’ .

    I have a thinkpad T410 with kinda similar graphiccard inside (NVIDIA Quadro NVS 3100M with 256MB)
    And it is working well with nouveau drivers and XFCE, i would not go with GNOME if you do not really need…

  • I did fresh install - no Nvidia drivers, chose KDE. Now on boot I see kernel messages scross, then I see a blank screen with cursor that moves but no activity. After sometime (I tried pressing a few keys after waiting for 10min) I see a ‘default theme error, using fallback’. After I choose fallback then Plasma loads.

    I see many earlier threads on this -

    https://forum.antergos.com/topic/5730/error-with-theme-and-system-login-process/15
    https://forum.antergos.com/topic/7736/login-impossible
    https://forum.antergos.com/topic/8655/installation-theme-and-login-problem

    I can try steps from those threads but I just want to know if this is expected.

  • The theme error will be gone after next reboot.

    And KDE is not a so called lighwight DE, it will be possible with finetuning of the complex configuration options to make it working very slick, also on older hardware, as i am not a KDE user i can not testify here.

  • Thanks. I don’t mind using other DEs but Gnome is too resource heavy for this old laptop - it uses 1.5-2GB out of my 4GB ram, KDE only uses 500MB.

  • @defc said in System won't boot after fresh install of Antergos:

    KDE only uses 500MB

    yes Antergos KDE Setup is very clean and minimal, because i was curious, i just install kde on my T60 and i find it working very slick, as you say i have i load under 500MB on kde itself, and also open chromium watching video on youtube load goes up to lightly under 800MB, thats useable of cause!

    But i can see tearing inside videostreams and also locally playing video gives tearing, i do not have this running i3 or XFCE +compton.

    But may it is different at yours as you have a more powerfull GPU.

  • @joekamprad Thanks a lot sir, your above post about arch chrooting really saved me today. I was completely stuck after the install. Thanks a lot! ☺

boot271 system126 fresh35 Posts 12Views 1105
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.