• Can't read VFAT drives

    I seem to have lost the capacity to read VFAT folders. Can anyone point me in the right direction? thanks

  • dosfstools missing?

  • It seems to be installed. The funny thing is that I formatted the USB drive from that machine to work on an Apple. When I came back to read the video on the original machine, it wouldn’t recognize the USB it formatted after it went through Apple :)

  • @33nicolas
    Want to reformat that USB drive with gparted? That may help if Apple has trashed the drive.
    Or can’t you read any VFAT partitions on any drive?

  • Yeah, I can’t read the drive I formatted under this machine after I put something on it from my other Apple computer. It’s frustrating. I have to look into opening a tunnel between those two. Grumble…

  • @33nicolas
    If gparted cannot use your USB drive, it is probably broken.
    But did you try creating a new partition table (msdos or gpt) to the USB drive?
    If that works, then you could reformat it to e.g. fat32 and start using it again…

  • Yeah, it’s weird. The problem is that the system doesn’t mount FAT32 or VFAT. It can format a vfat device but after it’s been used it can’t read it. The USB drives are all OK, the only other problem I see is the Apple computer.

    So far, all I know is that the system can partition and format vfat but can’t read them. I need to use something back and forth between OS.9 and here. Maybe I need to open Samab but even that is giving me difficulties.

  • @33nicolas said in Can't read VFAT drives:
    I need to use something back and forth between OS.9 and here. Maybe I need to open Samab but even that is giving me difficulties.

    I am not familiar with Apple at all. If OS.9 supports ext4 try using gparted to format your USB drives in ext4 format. Of course, with ext4 the USB drive would never work with Windows if that is a problem.


  • mac os as unixalike OS can work with sftp sshfs nfs also?

    Or access Linux filesystem with a tool like this: https://cyberduck.io/sftp/

  • @33nicolas
    It may be a simple problem: when managing a drive with gparted, the drive must be unmounted.
    So umount it first, then start gparted, then create a new partition table, and then format it.

  • @joekamprad said in Can't read VFAT drives:


    sftp needs only to enable sshd on you linux system*, then you can access from OSX with cyberduck, givvin your IP-adress username and password from Linuxmachine and open as filesystem.

    • sudo pacman -S openssh
    • sudo systemctl start sshd >> sudo systemctl enable sshd to start service every bootup…
  • @pudge Tx, seems I have to enable those options with Gparted.

  • @manuel But I’m trying to read it, not format it. Formatting isn’t the problem. Mounting after formatting and info on it is where I have the problem. I fail to see the solution here, sorry.

  • @joekamprad Yes, but I was hoping to open the network here and stay intra not Internet. But you’re right, it is a possibility.

  • @33nicolas
    MacOS supports two fat formats: FAT and ExFAT. I don’t know exactly what they are on Mac, but have you tried formatting the USB stick on Mac, copy the files there on Mac, and then read the files on you Antergos machine?
    You could test both formats with Mac. I’m quite sure it must be possible, since Mac should be able to format USB sticks to be used in Windows, too.

  • And when formatting on Mac, make sure the stick has either gpt or msdos partition map, not the Apple’s own partition map.

    You can check the partition map too in gparted.

  • @manuel Thanks, it was formatted on this Linux machine as Vfat to go to an Apple computer and bring a file over. Once I came back with the file that I put from the Apple on the USB drive, the Linux computer here won’t recognize the vfat drive it partitioned after Apple put something on it.

    I should figure out how to open up both computers on my local network perhaps.

  • @33nicolas said in Can't read VFAT drives:

    I should figure out how to open up both computers on my local network perhaps.

    I know nothing about a mac, but here is a tutorial on how to enable / disable SSH on a mac.
    Enable SSH on a mac

    From reading the tutorial, it looks like this will set the mac up as a SSH server. Then you can SSH into the mac from your Antergos machine.

    You are on your own as far as the mac. If you have trouble setting up a SSH client in Antergos, let me know and I will assist.

    Good luck. Remember: trying is learning.


  • @33nicolas
    Maybe I must rephrase:
    why don’t you just reformat the USB drive on Mac (to some FAT format)?

    I’d be very surprised if that stick couldn’t be read on Linux machine later.

  • But as others have suggested, you can transfer files from Mac to a Linux machine, e.g. using SSH, or many other network protocols.

drives9 vfat2 Posts 27Views 1274
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.